<!DOCTYPE html>
<html class="no-js" lang="en-US">
<head><script>if(navigator.userAgent.match(/MSIE|Internet Explorer/i)||navigator.userAgent.match(/Trident\/7\..*?rv:11/i)){var href=document.location.href;if(!href.match(/[?&]nowprocket/)){if(href.indexOf("?")==-1){if(href.indexOf("#")==-1){document.location.href=href+"?nowprocket=1"}else{document.location.href=href.replace("#","?nowprocket=1#")}}else{if(href.indexOf("#")==-1){document.location.href=href+"&nowprocket=1"}else{document.location.href=href.replace("#","&nowprocket=1#")}}}}</script><script>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</script>
<meta charset="UTF-8">
<meta name="google-site-verification" content="xkrJ0rSk8sSEq92tIV4hBiMQPSKheVMadhUWwCCTdIE" />
<link rel="shortcut icon" href="https://turfmagazine.com/wp-content/uploads/2015/02/turf_favicon.jpg" />
<meta charset="UTF-8">
<link href="//www.google-analytics.com" rel="dns-prefetch">
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
<meta name="viewport" content="width=device-width,initial-scale=1.0,user-scalable=yes">
<link rel="pingback" href="https://turfmagazine.com/xmlrpc.php" />



<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-NV35XJ5');</script>

<script type="text/javascript">
  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-120631451-2']);
  _gaq.push(['_trackPageview']);
  setTimeout("_gaq.push(['_trackEvent', '60_seconds', 'read'])",60000);
  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();
</script>

<script>
                            /* You can add more configuration options to webfontloader by previously defining the WebFontConfig with your options */
                            if ( typeof WebFontConfig === "undefined" ) {
                                WebFontConfig = new Object();
                            }
                            WebFontConfig['google'] = {families: ['Oswald:300,400,700', 'Open+Sans:300,400,600,700,800,300italic,400italic,600italic,700italic,800italic']};

                            (function() {
                                var wf = document.createElement( 'script' );
                                wf.src = 'https://ajax.googleapis.com/ajax/libs/webfont/1.5.3/webfont.js';
                                wf.type = 'text/javascript';
                                wf.async = 'true';
                                var s = document.getElementsByTagName( 'script' )[0];
                                s.parentNode.insertBefore( wf, s );
                            })();
                        </script>
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<title>STIHL Sponsors Philadelphia Flower Show</title>
<meta name="description" content="The PHS Philadelphia Flower Show, attracted hundreds of guests with its extravagant displays of innovative landscape design." />
<link rel="canonical" href="https://turfmagazine.com/tdb/stihl-sponsors-philadelphia-flower-show-highlighting-innovative-landscapers/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="STIHL Sponsors Philadelphia Flower Show" />
<meta property="og:description" content="The PHS Philadelphia Flower Show, attracted hundreds of guests with its extravagant displays of innovative landscape design." />
<meta property="og:url" content="https://turfmagazine.com/tdb/stihl-sponsors-philadelphia-flower-show-highlighting-innovative-landscapers/" />
<meta property="og:site_name" content="Turf Magazine" />
<meta property="article:publisher" content="https://www.facebook.com/TurfMagazine" />
<meta property="article:published_time" content="2022-06-24T05:36:23+00:00" />
<meta property="article:modified_time" content="2022-06-23T21:19:01+00:00" />
<meta property="og:image" content="https://turfmagazine.com/wp-content/uploads/2022/06/cl4bkwgbl4l1x8crawehlz49e-rcardillo-markcook.0.0.8256.5504.full_.jpg" />
<meta property="og:image:width" content="770" />
<meta property="og:image:height" content="513" />
<meta property="og:image:type" content="image/jpeg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@TurfMagazine" />
<meta name="twitter:site" content="@TurfMagazine" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Christine Menapace" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="2 minutes" />
<script type="application/ld+json" class="yoast-schema-graph">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</script>

<meta name="original-source" content="https://turfmagazine.com/tdb/stihl-sponsors-philadelphia-flower-show-highlighting-innovative-landscapers/" />
<link rel='dns-prefetch' href='//netdna.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//ssl.google-analytics.com' />
<link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link rel='dns-prefetch' href='//fonts.gstatic.com' />
<link rel="alternate" type="application/rss+xml" title="Turf Magazine &raquo; Feed" href="https://turfmagazine.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Turf Magazine &raquo; Comments Feed" href="https://turfmagazine.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Turf Magazine &raquo; STIHL Sponsors Philadelphia Flower Show Highlighting Innovative Landscapers Comments Feed" href="https://turfmagazine.com/tdb/stihl-sponsors-philadelphia-flower-show-highlighting-innovative-landscapers/feed/" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='selection-sharer-css' href='https://turfmagazine.com/wp-content/plugins/selection-sharer/css/selection-sharer.css?ver=0.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://turfmagazine.com/wp-includes/css/dist/block-library/style.min.css?ver=5.8.4' type='text/css' media='all' />
<link rel='stylesheet' id='pdfprnt_frontend-css' href='https://turfmagazine.com/wp-content/plugins/pdf-print-pro/css/frontend.css?ver=2.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='testimonial-rotator-style-css' href='https://turfmagazine.com/wp-content/plugins/testimonial-rotator/testimonial-rotator-style.css?ver=5.8.4' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css' href='//netdna.bootstrapcdn.com/font-awesome/latest/css/font-awesome.min.css?ver=5.8.4' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css' href='https://turfmagazine.com/wp-content/themes/presso2-0/style.css?ver=TD_THEME_VERSION' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-child-css' href='https://turfmagazine.com/wp-content/themes/tacocat/style.css?ver=TD_THEME_VERSIONc' type='text/css' media='all' />
<link rel='stylesheet' id='vwcss-flexslider-css' href='https://turfmagazine.com/wp-content/themes/presso2-0/framework/flexslider/flexslider-custom.css?ver=1.1%20tacOcat' type='text/css' media='all' />
<link rel='stylesheet' id='vwcss-icon-social-css' href='https://turfmagazine.com/wp-content/themes/presso2-0/framework/font-icons/social-icons/css/zocial.css?ver=1.1%20tacOcat' type='text/css' media='all' />
<link rel='stylesheet' id='vwcss-icon-entypo-css' href='https://turfmagazine.com/wp-content/themes/presso2-0/framework/font-icons/entypo/css/entypo.css?ver=1.1%20tacOcat' type='text/css' media='all' />
<link rel='stylesheet' id='vwcss-icon-symbol-css' href='https://turfmagazine.com/wp-content/themes/presso2-0/framework/font-icons/symbol/css/symbol.css?ver=1.1%20tacOcat' type='text/css' media='all' />
<link rel='stylesheet' id='vwcss-swipebox-css' href='https://turfmagazine.com/wp-content/themes/presso2-0/framework/swipebox/swipebox.css?ver=1.1%20tacOcat' type='text/css' media='all' />
<link rel='stylesheet' id='vwcss-bootstrap-css' href='https://turfmagazine.com/wp-content/themes/presso2-0/framework/bootstrap/css/bootstrap.css?ver=1.1%20tacOcat' type='text/css' media='all' />
<link rel='stylesheet' id='vwcss-theme-css' href='https://turfmagazine.com/wp-content/themes/presso2-0/css/theme.css?ver=1.1%20tacOcat' type='text/css' media='all' />
<script type='text/javascript' src='https://turfmagazine.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js' defer></script>
<script type='text/javascript' src='https://turfmagazine.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js' defer></script>
<script type='text/javascript' src='https://turfmagazine.com/wp-content/plugins/testimonial-rotator/js/jquery.cycletwo.js?ver=5.8.4' id='cycletwo-js' defer></script>
<script type='text/javascript' src='https://turfmagazine.com/wp-content/plugins/testimonial-rotator/js/jquery.cycletwo.addons.js?ver=5.8.4' id='cycletwo-addons-js' defer></script>
<script type='text/javascript' id='instant-search-js-extra'>
/* <![CDATA[ */
var instant_search = {"blog_url":"https:\/\/turfmagazine.com","ajax_url":"https:\/\/turfmagazine.com\/wp-admin\/admin-ajax.php","placeholder":"Search"};
/* ]]> */
</script>
<script type='text/javascript' src='https://turfmagazine.com/wp-content/themes/presso2-0/framework/instant-search/instant-search.js?ver=1.1%20tacOcat' id='instant-search-js' defer></script>
<link rel="https://api.w.org/" href="https://turfmagazine.com/wp-json/" /><link rel="alternate" type="application/json" href="https://turfmagazine.com/wp-json/wp/v2/posts/107029" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://turfmagazine.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://turfmagazine.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.8.4" />
<link rel='shortlink' href='https://turfmagazine.com/?p=107029' />
<link rel="alternate" type="application/json+oembed" href="https://turfmagazine.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fturfmagazine.com%2Ftdb%2Fstihl-sponsors-philadelphia-flower-show-highlighting-innovative-landscapers%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://turfmagazine.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fturfmagazine.com%2Ftdb%2Fstihl-sponsors-philadelphia-flower-show-highlighting-innovative-landscapers%2F&#038;format=xml" />
<link rel="preload" as="font" href="https://turfmagazine.com/wp-content/themes/presso2-0/framework/font-icons/social-icons/font/zocial.woff?97035448" crossorigin>
<link rel="preload" as="font" href="https://turfmagazine.com/wp-content/themes/presso2-0/framework/font-icons/entypo/font/entypo.woff?5488184" crossorigin><meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress." />
<style type="text/css" id="custom-background-css">
	body.custom-background.site-layout-boxed
	, body.custom-background.site-layout-full-large #off-canvas-body-inner
	, body.custom-background.site-layout-full-medium #off-canvas-body-inner
	{ background-image: url('https://turfmagazine.com/wp-content/uploads/2016/06/TURF-website-background.jpg'); background-repeat: no-repeat; background-position: top center; background-attachment: fixed; }
	</style>
<style id="vw-custom-font" type="text/css">
						
					</style>

<style type="text/css">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</style>
<style type="text/css" title="dynamic-css" class="options-output">h1, h2, h3, h4, h5, h6{font-family:Oswald;text-transform:uppercase;font-weight:700;font-style:normal;color:#333333;opacity: 1;visibility: visible;-webkit-transition: opacity 0.24s ease-in-out;-moz-transition: opacity 0.24s ease-in-out;transition: opacity 0.24s ease-in-out;}.wf-loading h1, h2, h3, h4, h5, h6,{opacity: 0;}.ie.wf-loading h1, h2, h3, h4, h5, h6,{visibility: hidden;}body{font-family:"Open Sans";font-weight:400;font-style:normal;color:#666666;font-size:14px;opacity: 1;visibility: visible;-webkit-transition: opacity 0.24s ease-in-out;-moz-transition: opacity 0.24s ease-in-out;transition: opacity 0.24s ease-in-out;}.wf-loading body,{opacity: 0;}.ie.wf-loading body,{visibility: hidden;}</style><noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>

<script type="rocketlazyloadscript">
var dfp_adDisplay_js = "/127596786/";
</script>

<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>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</script>

<script type="rocketlazyloadscript">
(function() {
var d=document,h=d.getElementsByTagName('head')[0],s=d.createElement('script'),sc = 'https:' == document.location.protocol ? 'https://' : 'http://';
s.type='text/javascript';
s.async=true;
s.src=sc+'s.dpmsrv.com/dpm_a2e33d344f272e100d4a8efeabc7ae8a60a8ba7a.min.js';
h.appendChild(s);
})();
</script>
<link rel="stylesheet" href="https://olytics.omeda.com/olytics/css/v3/p/olytics.css" />
<script type="text/javascript">
// olytics 3.0
window.olytics||(window.olytics=[]),window.olytics.methods=["fire","confirm"],window.olytics.factory=function(i){return function(){var t=Array.prototype.slice.call(arguments);return t.unshift(i),window.olytics.push(t),window.olytics}};for(var i=0;i<window.olytics.methods.length;i++){var method=window.olytics.methods[i];window.olytics[method]=window.olytics.factory(method)}olytics.load=function(i){if(!document.getElementById("olyticsImport")){window.a=window.olytics;var t=document.createElement("script");t.async=!0,t.id="olyticsImport",t.type="text/javascript";var o="";void 0!==i&&void 0!==i.oid&&(o=i.oid),t.setAttribute("data-oid",o),t.src="https://olytics.omeda.com/olytics/js/v3/p/olytics.min.js",t.addEventListener("load",function(t){for(olytics.initialize({Olytics:i});window.a.length>0;){var o=window.a.shift(),s=o.shift();olytics[s]&&olytics[s].apply(olytics,o)}},!1);var s=document.getElementsByTagName("script")[0];s.parentNode.insertBefore(t,s)}},olytics.load({oid:"f9de0b4e493140a4a418cae729c12b6a"});
</script>
<script type="rocketlazyloadscript"> 

olytics.fire( 

    { 

    behaviorId: '4014E3567790A2D', 

    category: "Contractor Profiles, Design, Build &amp; Installation, Industry News, Innovation, Manufacturer/Supplier Updates, Plants, The Latest, Turf Design Build",

    tag: "Award Winning Landscapers, Innovative Landscape Design, Irwin Landscaping, Jeff Cartwright, Mark Cook Landscape &amp; Contracting, Philadelphia Flower Show, Refugia Design, Sara Bendrick, STIHL, Susan Cohan Gardens"

  } 

); 

</script>
<style type="text/css">
    html {
    height: 100%;
    overflow: hidden;
    width: 100%;
}

body {
    height: 100%;
    overflow-x: hidden;
    overflow-y: auto;
    width: 100%;
}
</style>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-7839309036119988" crossorigin="anonymous"></script>
</head>
<body id="top" class="post-template-default single single-post postid-107029 single-format-standard custom-background site-layout-boxed site-disable-post-box-effects contractor-profiles landscape-designbuildinstallation industry-news innovation manufacturersupplier-updates nurseryplant-materials the-latest tdb wpb-js-composer js-comp-ver-6.9.0 vc_responsive">

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-NV35XJ5"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<br>

<center>
<div id="div-gpt-ad-1467129242315-1">
<script type="text/javascript">
googletag.cmd.push(function() {
googletag.display("div-gpt-ad-1467129242315-1");
});
</script>
</div>
</center>
<nav id="mobile-nav-wrapper"></nav>
<div id="off-canvas-body-inner">


<div id="top-bar" class="top-bar">
<div class="container">
<div class="row">
<div class="col-sm-12">
<div class="top-bar-right">
<a class="site-social-icon" href="https://www.facebook.com/TurfMagazine" title="Facebook" target="_blank"><i class="icon-social-facebook"></i></a><a class="site-social-icon" href="https://www.linkedin.com/company/turf-magazine/" title="LinkedIn" target="_blank"><i class="icon-social-linkedin"></i></a><a class="site-social-icon" href="https://www.pinterest.com/commercial_industry_news/turf-magazine-news/" title="Pinterest" target="_blank"><i class="icon-social-pinterest"></i></a><a class="site-social-icon" href="https://turfmagazine.com/feed/" title="RSS" target="_blank"><i class="icon-social-rss"></i></a><a class="site-social-icon" href="https://twitter.com/TurfMagazine" title="Twitter" target="_blank"><i class="icon-social-twitter"></i></a><a class="site-social-icon" href="https://www.youtube.com/channel/UCKAs593uOT-TYoyi0zXH4_Q" title="Youtube" target="_blank"><i class="icon-social-youtube"></i></a>
<a class="instant-search-icon" href="#menu1"><i class="icon-entypo-search"></i></a>
</div>
<a id="open-mobile-nav" href="#mobile-nav" title="Search"><i class="icon-entypo-menu"></i></a>
<nav id="top-nav-wrapper">
<ul id="menu-header" class="top-nav list-unstyled clearfix"><li id="nav-menu-item-318" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a target="_blank" href="#" class="menu-link main-menu-link"><span>Subscribe</span></a>
<ul class="sub-menu menu-odd  menu-depth-1">
<li id="nav-menu-item-94602" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="https://groupcmedia.dragonforms.com/TRFland" class="menu-link sub-menu-link"><span>Magazine</span></a></li>
<li id="nav-menu-item-34651" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="https://groupcmedia.dragonforms.com/loading.do?omedasite=TRF_pref_page" class="menu-link sub-menu-link"><span>Newsletter</span></a></li>
<li id="nav-menu-item-96846" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="https://lsc-pagepro.mydigitalpublication.com/publication/?m=59765&amp;l=1&amp;view=issuelistBrowser" class="menu-link sub-menu-link"><span>Back Issues</span></a></li>
</ul>
</li>
<li id="nav-menu-item-104020" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-custom menu-item-object-custom"><a href="https://lsc-pagepro.mydigitalpublication.com/publication/?m=59765&amp;l=1&amp;view=issuelistBrowser" class="menu-link main-menu-link"><span>Digital Editions</span></a></li>
<li id="nav-menu-item-102734" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://turf.hotims.com/" class="menu-link main-menu-link"><span>Free Product Info</span></a></li>
<li id="nav-menu-item-532" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-post_type menu-item-object-page"><a href="https://turfmagazine.com/reprints/" class="menu-link main-menu-link"><span>Reprints</span></a></li>
<li id="nav-menu-item-665" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-post_type menu-item-object-page"><a href="https://turfmagazine.com/about-us/" class="menu-link main-menu-link"><span>About Us</span></a></li>
<li id="nav-menu-item-94417" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="https://turfmagazine.com/advertise-with-us/" class="menu-link main-menu-link"><span>Advertise</span></a>
<ul class="sub-menu menu-odd  menu-depth-1">
<li id="nav-menu-item-102181" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="https://turfmagazine.com/advertise-with-us/" class="menu-link sub-menu-link"><span>Media Kit</span></a></li>
<li id="nav-menu-item-102180" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="https://turfmagazine.com/editorial-calendar/" class="menu-link sub-menu-link"><span>Turf Editorial Calendar</span></a></li>
</ul>
</li>
<li id="nav-menu-item-477" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-post_type menu-item-object-page"><a href="https://turfmagazine.com/contact-us/" class="menu-link main-menu-link"><span>Contact Us</span></a></li>
</ul> </nav>
</div>
</div>
</div>
</div>


<header class="main-bar header-layout-left-logo">
<div class="container">
<div class="row">
<div class="col-sm-12">
<div id="logo" class="">
<a href="https://turfmagazine.com/">
<img src="https://turfmagazine.com/wp-content/uploads/2020/04/TURFLogoRegisterMark-Retina.png" width="203" height="90" alt="Turf Magazine" class="logo-retina" />
<img src="https://turfmagazine.com/wp-content/uploads/2020/04/TurfLogo-RegisterMark-203x90.png" width="203" height="90" alt="Turf Magazine" class="logo-original" />
<h2 id="site-tagline" class="subtitle">Turf keeps landscape and design/build professionals up-to-date on emerging trends, best practices, operational efficiencies, marketing/sales &amp; human development.</h2>
</a>
</div>
<div class="header-ads">

<div id="div-gpt-ad-1467129242315-4">
<script type="text/javascript">
googletag.cmd.push(function() {
googletag.display("div-gpt-ad-1467129242315-4");
});
</script>
</div> </div>
</div>
</div>
</div>
</header>


<div class="main-nav-bar header-layout-left-logo">
<div class="container">
<div class="row">
<div class="col-sm-12">
<nav id="main-nav-wrapper"><ul id="menu-main" class="main-nav list-unstyled"><li id="nav-menu-item-8079" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="https://turfmagazine.com/category/business-management/" class="menu-link main-menu-link"><span>Business Management</span></a><div class="sub-menu-container">
<ul class="sub-menu menu-odd  menu-depth-1">
<li id="nav-menu-item-8091" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent"><a href="https://turfmagazine.com/category/industry-news/" class="menu-link sub-menu-link"><span>Industry News</span></a></li>
<li id="nav-menu-item-8088" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://turfmagazine.com/category/resources/" class="menu-link sub-menu-link"><span>Resources</span></a></li>
</ul>
<ul class="sub-posts">
<li class="col-sm-4"><article class="post-107001 post-box post-box-large-thumbnail">
<div class="post-thumbnail-wrapper">
<a href="https://turfmagazine.com/safety/national-hydration-day-the-most-effective-outdoor-work-drink-options/" title="Permalink to National Hydration Day: The Most Effective Outdoor Work Drink Options" rel="bookmark">
<img width="360" height="200" src="https://turfmagazine.com/wp-content/uploads/2022/06/Screen-Shot-2022-06-23-at-12.04.13-PM-360x200.png" class="attachment-vw_small size-vw_small wp-post-image" alt="" loading="lazy" srcset="https://turfmagazine.com/wp-content/uploads/2022/06/Screen-Shot-2022-06-23-at-12.04.13-PM-360x200.png 360w, https://turfmagazine.com/wp-content/uploads/2022/06/Screen-Shot-2022-06-23-at-12.04.13-PM-265x147.png 265w" sizes="(max-width: 360px) 100vw, 360px" /> </a>
</div>
<div class="post-box-inner">
<h3 class="title"><a href="https://turfmagazine.com/safety/national-hydration-day-the-most-effective-outdoor-work-drink-options/" title="Permalink to National Hydration Day: The Most Effective Outdoor Work Drink Options" rel="bookmark">National Hydration Day: The Most Effective Outdoor Work Drink Options</a></h3>
<div class="post-meta header-font">
<img alt='' src='https://secure.gravatar.com/avatar/883b894c473d2403ac745d41928703d4?s=32&#038;r=r' srcset='https://secure.gravatar.com/avatar/883b894c473d2403ac745d41928703d4?s=64&#038;r=r 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy' /> <a class="author-name" href="https://turfmagazine.com/author/cmenapace/" title="View all posts by Christine Menapace">Christine Menapace</a><span class="post-meta-separator">,</span>
<a href="https://turfmagazine.com/safety/national-hydration-day-the-most-effective-outdoor-work-drink-options/" class="post-date" title="Permalink to National Hydration Day: The Most Effective Outdoor Work Drink Options" rel="bookmark">June 23, 2022</a>
</div>
</div>
</article></li><li class="col-sm-4"><article class="post-106931 post-box post-box-large-thumbnail">
<div class="post-thumbnail-wrapper">
<a href="https://turfmagazine.com/manufacturersupplier-updates/rc-mowers-continues-great-american-roadshow-into-summer/" title="Permalink to RC Mowers Continues Great American Road Show Into The Summer" rel="bookmark">
<img width="360" height="200" src="https://turfmagazine.com/wp-content/uploads/2022/06/Mowers-with-Truck-360x200.jpg" class="attachment-vw_small size-vw_small wp-post-image" alt="RC Mowers" loading="lazy" srcset="https://turfmagazine.com/wp-content/uploads/2022/06/Mowers-with-Truck-360x200.jpg 360w, https://turfmagazine.com/wp-content/uploads/2022/06/Mowers-with-Truck-265x147.jpg 265w" sizes="(max-width: 360px) 100vw, 360px" /> </a>
</div>
<div class="post-box-inner">
<h3 class="title"><a href="https://turfmagazine.com/manufacturersupplier-updates/rc-mowers-continues-great-american-roadshow-into-summer/" title="Permalink to RC Mowers Continues Great American Road Show Into The Summer" rel="bookmark">RC Mowers Continues Great American Road Show Into The Summer</a></h3>
<div class="post-meta header-font">
<img alt='' src='https://secure.gravatar.com/avatar/edb1283861b8dfeca9b1ff1e1f3f2121?s=32&#038;r=r' srcset='https://secure.gravatar.com/avatar/edb1283861b8dfeca9b1ff1e1f3f2121?s=64&#038;r=r 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy' /> <a class="author-name" href="https://turfmagazine.com/author/jschwartz/" title="View all posts by Jessica Schwartz">Jessica Schwartz</a><span class="post-meta-separator">,</span>
<a href="https://turfmagazine.com/manufacturersupplier-updates/rc-mowers-continues-great-american-roadshow-into-summer/" class="post-date" title="Permalink to RC Mowers Continues Great American Road Show Into The Summer" rel="bookmark">June 22, 2022</a>
</div>
</div>
</article></li><li class="col-sm-4"><article class="post-106981 post-box post-box-large-thumbnail">
<div class="post-thumbnail-wrapper">
<a href="https://turfmagazine.com/business-management/evaluating-innovation-in-the-lawn-and-landscape-industry/" title="Permalink to Evaluating Innovation In The Lawn And Landscape Industry" rel="bookmark">
<img width="360" height="200" src="https://turfmagazine.com/wp-content/uploads/2022/06/d608f4de-9446-4e12-a021-88568301992c-360x200.jpg" class="attachment-vw_small size-vw_small wp-post-image" alt="" loading="lazy" srcset="https://turfmagazine.com/wp-content/uploads/2022/06/d608f4de-9446-4e12-a021-88568301992c-360x200.jpg 360w, https://turfmagazine.com/wp-content/uploads/2022/06/d608f4de-9446-4e12-a021-88568301992c-265x147.jpg 265w" sizes="(max-width: 360px) 100vw, 360px" /> </a>
</div>
<div class="post-box-inner">
<h3 class="title"><a href="https://turfmagazine.com/business-management/evaluating-innovation-in-the-lawn-and-landscape-industry/" title="Permalink to Evaluating Innovation In The Lawn And Landscape Industry" rel="bookmark">Evaluating Innovation In The Lawn And Landscape Industry</a></h3>
<div class="post-meta header-font">
<img alt='' src='https://secure.gravatar.com/avatar/a2bd58988de28fb95eef5c074f376934?s=32&#038;r=r' srcset='https://secure.gravatar.com/avatar/a2bd58988de28fb95eef5c074f376934?s=64&#038;r=r 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy' /> <a class="author-name" href="https://turfmagazine.com/author/turf-editors/" title="View all posts by Turf Editors">Turf Editors</a><span class="post-meta-separator">,</span>
<a href="https://turfmagazine.com/business-management/evaluating-innovation-in-the-lawn-and-landscape-industry/" class="post-date" title="Permalink to Evaluating Innovation In The Lawn And Landscape Industry" rel="bookmark">June 17, 2022</a>
</div>
</div>
</article></li> </ul>
</div>
</li>
<li id="nav-menu-item-8067" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="https://turfmagazine.com/category/services/" class="menu-link main-menu-link"><span>Services</span></a><div class="sub-menu-container">
<ul class="sub-menu menu-odd  menu-depth-1">
<li id="nav-menu-item-8075" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://turfmagazine.com/category/maintenance/" class="menu-link sub-menu-link"><span>Maintenance</span></a></li>
<li id="nav-menu-item-8074" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://turfmagazine.com/category/lawn-care/" class="menu-link sub-menu-link"><span>Lawn Care</span></a></li>
<li id="nav-menu-item-8072" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent"><a href="https://turfmagazine.com/category/landscape-designbuildinstallation/" class="menu-link sub-menu-link"><span>Design/Build/Installation</span></a></li>
<li id="nav-menu-item-78899" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://turfmagazine.com/category/all-tree-services/" class="menu-link sub-menu-link"><span>Tree Services</span></a></li>
<li id="nav-menu-item-8070" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://turfmagazine.com/category/hardscapes/" class="menu-link sub-menu-link"><span>Hardscapes</span></a></li>
<li id="nav-menu-item-8076" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://turfmagazine.com/category/plow/" class="menu-link sub-menu-link"><span>Snow &#038; Ice Management</span></a></li>
<li id="nav-menu-item-8086" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://turfmagazine.com/category/irrigation/" class="menu-link sub-menu-link"><span>Irrigation</span></a></li>
</ul>
<ul class="sub-posts">
<li class="col-sm-4"><article class="post-106893 post-box post-box-large-thumbnail">
<div class="post-thumbnail-wrapper">
<a href="https://turfmagazine.com/manufacturersupplier-updates/ken-catalano-vp-landscape-nursery-sales-florida-coast-equipment/" title="Permalink to Ken Catalano Named VP of Landscape &#038; Nursery Sales at Florida Coast Equipment" rel="bookmark">
<img width="360" height="200" src="https://turfmagazine.com/wp-content/uploads/2022/06/Ken-Head-Shot-360x200.jpg" class="attachment-vw_small size-vw_small wp-post-image" alt="Ken Catalano" loading="lazy" srcset="https://turfmagazine.com/wp-content/uploads/2022/06/Ken-Head-Shot-360x200.jpg 360w, https://turfmagazine.com/wp-content/uploads/2022/06/Ken-Head-Shot-265x147.jpg 265w" sizes="(max-width: 360px) 100vw, 360px" /> </a>
</div>
<div class="post-box-inner">
<h3 class="title"><a href="https://turfmagazine.com/manufacturersupplier-updates/ken-catalano-vp-landscape-nursery-sales-florida-coast-equipment/" title="Permalink to Ken Catalano Named VP of Landscape &#038; Nursery Sales at Florida Coast Equipment" rel="bookmark">Ken Catalano Named VP of Landscape &#038; Nursery Sales at Florida Coast Equipment</a></h3>
<div class="post-meta header-font">
<img alt='' src='https://secure.gravatar.com/avatar/edb1283861b8dfeca9b1ff1e1f3f2121?s=32&#038;r=r' srcset='https://secure.gravatar.com/avatar/edb1283861b8dfeca9b1ff1e1f3f2121?s=64&#038;r=r 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy' /> <a class="author-name" href="https://turfmagazine.com/author/jschwartz/" title="View all posts by Jessica Schwartz">Jessica Schwartz</a><span class="post-meta-separator">,</span>
<a href="https://turfmagazine.com/manufacturersupplier-updates/ken-catalano-vp-landscape-nursery-sales-florida-coast-equipment/" class="post-date" title="Permalink to Ken Catalano Named VP of Landscape &#038; Nursery Sales at Florida Coast Equipment" rel="bookmark">June 15, 2022</a>
</div>
</div>
</article></li><li class="col-sm-4"><article class="post-106767 post-box post-box-large-thumbnail">
<div class="post-thumbnail-wrapper">
<a href="https://turfmagazine.com/charitable-work/ruppert-landscape-helps-restore-long-branch-community-center/" title="Permalink to Ruppert Landscape Helps Restore Long Branch Community Center" rel="bookmark">
<img width="360" height="200" src="https://turfmagazine.com/wp-content/uploads/2022/05/ruppert-image-360x200.jpg" class="attachment-vw_small size-vw_small wp-post-image" alt="Ruppert Community Center" loading="lazy" srcset="https://turfmagazine.com/wp-content/uploads/2022/05/ruppert-image-360x200.jpg 360w, https://turfmagazine.com/wp-content/uploads/2022/05/ruppert-image-265x147.jpg 265w" sizes="(max-width: 360px) 100vw, 360px" /> </a>
</div>
<div class="post-box-inner">
<h3 class="title"><a href="https://turfmagazine.com/charitable-work/ruppert-landscape-helps-restore-long-branch-community-center/" title="Permalink to Ruppert Landscape Helps Restore Long Branch Community Center" rel="bookmark">Ruppert Landscape Helps Restore Long Branch Community Center</a></h3>
<div class="post-meta header-font">
<img alt='' src='https://secure.gravatar.com/avatar/edb1283861b8dfeca9b1ff1e1f3f2121?s=32&#038;r=r' srcset='https://secure.gravatar.com/avatar/edb1283861b8dfeca9b1ff1e1f3f2121?s=64&#038;r=r 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy' /> <a class="author-name" href="https://turfmagazine.com/author/jschwartz/" title="View all posts by Jessica Schwartz">Jessica Schwartz</a><span class="post-meta-separator">,</span>
<a href="https://turfmagazine.com/charitable-work/ruppert-landscape-helps-restore-long-branch-community-center/" class="post-date" title="Permalink to Ruppert Landscape Helps Restore Long Branch Community Center" rel="bookmark">May 24, 2022</a>
</div>
</div>
</article></li><li class="col-sm-4"><article class="post-106659 post-box post-box-large-thumbnail">
<div class="post-thumbnail-wrapper">
<a href="https://turfmagazine.com/tdb/secretary-haaland-announces-61-million-to-increase-outdoor-opportunities-in-urban-areas/" title="Permalink to Secretary Haaland Announces $61 Million to Increase Outdoor Opportunities in Urban Areas" rel="bookmark">
<img width="360" height="200" src="https://turfmagazine.com/wp-content/uploads/2022/05/MN-2-360x200.jpg" class="attachment-vw_small size-vw_small wp-post-image" alt="Secretary Haaland" loading="lazy" srcset="https://turfmagazine.com/wp-content/uploads/2022/05/MN-2-360x200.jpg 360w, https://turfmagazine.com/wp-content/uploads/2022/05/MN-2-265x147.jpg 265w" sizes="(max-width: 360px) 100vw, 360px" /> </a>
</div>
<div class="post-box-inner">
<h3 class="title"><a href="https://turfmagazine.com/tdb/secretary-haaland-announces-61-million-to-increase-outdoor-opportunities-in-urban-areas/" title="Permalink to Secretary Haaland Announces $61 Million to Increase Outdoor Opportunities in Urban Areas" rel="bookmark">Secretary Haaland Announces $61 Million to Increase Outdoor Opportunities in Urban Areas</a></h3>
<div class="post-meta header-font">
<img alt='' src='https://secure.gravatar.com/avatar/edb1283861b8dfeca9b1ff1e1f3f2121?s=32&#038;r=r' srcset='https://secure.gravatar.com/avatar/edb1283861b8dfeca9b1ff1e1f3f2121?s=64&#038;r=r 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy' /> <a class="author-name" href="https://turfmagazine.com/author/jschwartz/" title="View all posts by Jessica Schwartz">Jessica Schwartz</a><span class="post-meta-separator">,</span>
<a href="https://turfmagazine.com/tdb/secretary-haaland-announces-61-million-to-increase-outdoor-opportunities-in-urban-areas/" class="post-date" title="Permalink to Secretary Haaland Announces $61 Million to Increase Outdoor Opportunities in Urban Areas" rel="bookmark">May 17, 2022</a>
</div>
</div>
</article></li> </ul>
</div>
</li>
<li id="nav-menu-item-36394" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent"><a href="https://turfmagazine.com/category/nurseryplant-materials/" class="menu-link main-menu-link"><span>Plants</span></a><div class="sub-menu-container"> <ul class="sub-posts">
<li class="col-sm-4"><article class="post-107029 post-box post-box-large-thumbnail">
<div class="post-thumbnail-wrapper">
<a href="https://turfmagazine.com/tdb/stihl-sponsors-philadelphia-flower-show-highlighting-innovative-landscapers/" title="Permalink to STIHL Sponsors Philadelphia Flower Show Highlighting Innovative Landscapers" rel="bookmark">
<img width="360" height="200" src="https://turfmagazine.com/wp-content/uploads/2022/06/cl4bkwgbl4l1x8crawehlz49e-rcardillo-markcook.0.0.8256.5504.full_-360x200.jpg" class="attachment-vw_small size-vw_small wp-post-image" alt="" loading="lazy" srcset="https://turfmagazine.com/wp-content/uploads/2022/06/cl4bkwgbl4l1x8crawehlz49e-rcardillo-markcook.0.0.8256.5504.full_-360x200.jpg 360w, https://turfmagazine.com/wp-content/uploads/2022/06/cl4bkwgbl4l1x8crawehlz49e-rcardillo-markcook.0.0.8256.5504.full_-265x147.jpg 265w" sizes="(max-width: 360px) 100vw, 360px" /> </a>
</div>
<div class="post-box-inner">
<h3 class="title"><a href="https://turfmagazine.com/tdb/stihl-sponsors-philadelphia-flower-show-highlighting-innovative-landscapers/" title="Permalink to STIHL Sponsors Philadelphia Flower Show Highlighting Innovative Landscapers" rel="bookmark">STIHL Sponsors Philadelphia Flower Show Highlighting Innovative Landscapers</a></h3>
<div class="post-meta header-font">
<img alt='' src='https://secure.gravatar.com/avatar/883b894c473d2403ac745d41928703d4?s=32&#038;r=r' srcset='https://secure.gravatar.com/avatar/883b894c473d2403ac745d41928703d4?s=64&#038;r=r 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy' /> <a class="author-name" href="https://turfmagazine.com/author/cmenapace/" title="View all posts by Christine Menapace">Christine Menapace</a><span class="post-meta-separator">,</span>
<a href="https://turfmagazine.com/tdb/stihl-sponsors-philadelphia-flower-show-highlighting-innovative-landscapers/" class="post-date" title="Permalink to STIHL Sponsors Philadelphia Flower Show Highlighting Innovative Landscapers" rel="bookmark">June 24, 2022</a>
</div>
</div>
</article></li><li class="col-sm-4"><article class="post-106943 post-box post-box-large-thumbnail">
<div class="post-thumbnail-wrapper">
<a href="https://turfmagazine.com/industry-news/milans-botanical-garden-transformed-to-explore-energy/" title="Permalink to Milan&#8217;s Botanical Garden Transformed To Explore Energy" rel="bookmark">
<img width="360" height="200" src="https://turfmagazine.com/wp-content/uploads/2022/06/e633167d-d07e-9e4f-6cf2-502ea7a67baa-360x200.jpg" class="attachment-vw_small size-vw_small wp-post-image" alt="energy" loading="lazy" srcset="https://turfmagazine.com/wp-content/uploads/2022/06/e633167d-d07e-9e4f-6cf2-502ea7a67baa-360x200.jpg 360w, https://turfmagazine.com/wp-content/uploads/2022/06/e633167d-d07e-9e4f-6cf2-502ea7a67baa-265x147.jpg 265w" sizes="(max-width: 360px) 100vw, 360px" /> </a>
</div>
<div class="post-box-inner">
<h3 class="title"><a href="https://turfmagazine.com/industry-news/milans-botanical-garden-transformed-to-explore-energy/" title="Permalink to Milan&#8217;s Botanical Garden Transformed To Explore Energy" rel="bookmark">Milan&#8217;s Botanical Garden Transformed To Explore Energy</a></h3>
<div class="post-meta header-font">
<img alt='' src='https://secure.gravatar.com/avatar/883b894c473d2403ac745d41928703d4?s=32&#038;r=r' srcset='https://secure.gravatar.com/avatar/883b894c473d2403ac745d41928703d4?s=64&#038;r=r 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy' /> <a class="author-name" href="https://turfmagazine.com/author/cmenapace/" title="View all posts by Christine Menapace">Christine Menapace</a><span class="post-meta-separator">,</span>
<a href="https://turfmagazine.com/industry-news/milans-botanical-garden-transformed-to-explore-energy/" class="post-date" title="Permalink to Milan&#8217;s Botanical Garden Transformed To Explore Energy" rel="bookmark">June 14, 2022</a>
</div>
</div>
</article></li><li class="col-sm-4"><article class="post-106875 post-box post-box-large-thumbnail">
<div class="post-thumbnail-wrapper">
<a href="https://turfmagazine.com/manufacturersupplier-updates/the-grass-really-is-greener-on-the-gavranovic-side-of-the-fence/" title="Permalink to The Grass Really Is Greener On The Gavranovic Side Of The Fence" rel="bookmark">
<img width="360" height="200" src="https://turfmagazine.com/wp-content/uploads/2022/05/Celebration-at-Horizon-Grass-Farms-1-360x200.jpg" class="attachment-vw_small size-vw_small wp-post-image" alt="Grass" loading="lazy" srcset="https://turfmagazine.com/wp-content/uploads/2022/05/Celebration-at-Horizon-Grass-Farms-1-360x200.jpg 360w, https://turfmagazine.com/wp-content/uploads/2022/05/Celebration-at-Horizon-Grass-Farms-1-265x147.jpg 265w" sizes="(max-width: 360px) 100vw, 360px" /> </a>
</div>
<div class="post-box-inner">
<h3 class="title"><a href="https://turfmagazine.com/manufacturersupplier-updates/the-grass-really-is-greener-on-the-gavranovic-side-of-the-fence/" title="Permalink to The Grass Really Is Greener On The Gavranovic Side Of The Fence" rel="bookmark">The Grass Really Is Greener On The Gavranovic Side Of The Fence</a></h3>
<div class="post-meta header-font">
<img alt='' src='https://secure.gravatar.com/avatar/2dba863655ac03cdb4ecdf395e0547d2?s=32&#038;r=r' srcset='https://secure.gravatar.com/avatar/2dba863655ac03cdb4ecdf395e0547d2?s=64&#038;r=r 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy' /> <a class="author-name" href="https://turfmagazine.com/author/c-brown/" title="View all posts by C Brown">C Brown</a><span class="post-meta-separator">,</span>
<a href="https://turfmagazine.com/manufacturersupplier-updates/the-grass-really-is-greener-on-the-gavranovic-side-of-the-fence/" class="post-date" title="Permalink to The Grass Really Is Greener On The Gavranovic Side Of The Fence" rel="bookmark">June 8, 2022</a>
</div>
</div>
</article></li> </ul>
</div>
</li>
<li id="nav-menu-item-8087" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://turfmagazine.com/category/products/" class="menu-link main-menu-link"><span>Products</span></a><div class="sub-menu-container"> <ul class="sub-posts">
<li class="col-sm-4"><article class="post-107001 post-box post-box-large-thumbnail">
<div class="post-thumbnail-wrapper">
<a href="https://turfmagazine.com/safety/national-hydration-day-the-most-effective-outdoor-work-drink-options/" title="Permalink to National Hydration Day: The Most Effective Outdoor Work Drink Options" rel="bookmark">
<img width="360" height="200" src="https://turfmagazine.com/wp-content/uploads/2022/06/Screen-Shot-2022-06-23-at-12.04.13-PM-360x200.png" class="attachment-vw_small size-vw_small wp-post-image" alt="" loading="lazy" srcset="https://turfmagazine.com/wp-content/uploads/2022/06/Screen-Shot-2022-06-23-at-12.04.13-PM-360x200.png 360w, https://turfmagazine.com/wp-content/uploads/2022/06/Screen-Shot-2022-06-23-at-12.04.13-PM-265x147.png 265w" sizes="(max-width: 360px) 100vw, 360px" /> </a>
</div>
<div class="post-box-inner">
<h3 class="title"><a href="https://turfmagazine.com/safety/national-hydration-day-the-most-effective-outdoor-work-drink-options/" title="Permalink to National Hydration Day: The Most Effective Outdoor Work Drink Options" rel="bookmark">National Hydration Day: The Most Effective Outdoor Work Drink Options</a></h3>
<div class="post-meta header-font">
<img alt='' src='https://secure.gravatar.com/avatar/883b894c473d2403ac745d41928703d4?s=32&#038;r=r' srcset='https://secure.gravatar.com/avatar/883b894c473d2403ac745d41928703d4?s=64&#038;r=r 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy' /> <a class="author-name" href="https://turfmagazine.com/author/cmenapace/" title="View all posts by Christine Menapace">Christine Menapace</a><span class="post-meta-separator">,</span>
<a href="https://turfmagazine.com/safety/national-hydration-day-the-most-effective-outdoor-work-drink-options/" class="post-date" title="Permalink to National Hydration Day: The Most Effective Outdoor Work Drink Options" rel="bookmark">June 23, 2022</a>
</div>
</div>
</article></li><li class="col-sm-4"><article class="post-106931 post-box post-box-large-thumbnail">
<div class="post-thumbnail-wrapper">
<a href="https://turfmagazine.com/manufacturersupplier-updates/rc-mowers-continues-great-american-roadshow-into-summer/" title="Permalink to RC Mowers Continues Great American Road Show Into The Summer" rel="bookmark">
<img width="360" height="200" src="https://turfmagazine.com/wp-content/uploads/2022/06/Mowers-with-Truck-360x200.jpg" class="attachment-vw_small size-vw_small wp-post-image" alt="RC Mowers" loading="lazy" srcset="https://turfmagazine.com/wp-content/uploads/2022/06/Mowers-with-Truck-360x200.jpg 360w, https://turfmagazine.com/wp-content/uploads/2022/06/Mowers-with-Truck-265x147.jpg 265w" sizes="(max-width: 360px) 100vw, 360px" /> </a>
</div>
<div class="post-box-inner">
<h3 class="title"><a href="https://turfmagazine.com/manufacturersupplier-updates/rc-mowers-continues-great-american-roadshow-into-summer/" title="Permalink to RC Mowers Continues Great American Road Show Into The Summer" rel="bookmark">RC Mowers Continues Great American Road Show Into The Summer</a></h3>
<div class="post-meta header-font">
<img alt='' src='https://secure.gravatar.com/avatar/edb1283861b8dfeca9b1ff1e1f3f2121?s=32&#038;r=r' srcset='https://secure.gravatar.com/avatar/edb1283861b8dfeca9b1ff1e1f3f2121?s=64&#038;r=r 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy' /> <a class="author-name" href="https://turfmagazine.com/author/jschwartz/" title="View all posts by Jessica Schwartz">Jessica Schwartz</a><span class="post-meta-separator">,</span>
<a href="https://turfmagazine.com/manufacturersupplier-updates/rc-mowers-continues-great-american-roadshow-into-summer/" class="post-date" title="Permalink to RC Mowers Continues Great American Road Show Into The Summer" rel="bookmark">June 22, 2022</a>
</div>
</div>
</article></li><li class="col-sm-4"><article class="post-106981 post-box post-box-large-thumbnail">
<div class="post-thumbnail-wrapper">
<a href="https://turfmagazine.com/business-management/evaluating-innovation-in-the-lawn-and-landscape-industry/" title="Permalink to Evaluating Innovation In The Lawn And Landscape Industry" rel="bookmark">
<img width="360" height="200" src="https://turfmagazine.com/wp-content/uploads/2022/06/d608f4de-9446-4e12-a021-88568301992c-360x200.jpg" class="attachment-vw_small size-vw_small wp-post-image" alt="" loading="lazy" srcset="https://turfmagazine.com/wp-content/uploads/2022/06/d608f4de-9446-4e12-a021-88568301992c-360x200.jpg 360w, https://turfmagazine.com/wp-content/uploads/2022/06/d608f4de-9446-4e12-a021-88568301992c-265x147.jpg 265w" sizes="(max-width: 360px) 100vw, 360px" /> </a>
</div>
<div class="post-box-inner">
<h3 class="title"><a href="https://turfmagazine.com/business-management/evaluating-innovation-in-the-lawn-and-landscape-industry/" title="Permalink to Evaluating Innovation In The Lawn And Landscape Industry" rel="bookmark">Evaluating Innovation In The Lawn And Landscape Industry</a></h3>
<div class="post-meta header-font">
<img alt='' src='https://secure.gravatar.com/avatar/a2bd58988de28fb95eef5c074f376934?s=32&#038;r=r' srcset='https://secure.gravatar.com/avatar/a2bd58988de28fb95eef5c074f376934?s=64&#038;r=r 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy' /> <a class="author-name" href="https://turfmagazine.com/author/turf-editors/" title="View all posts by Turf Editors">Turf Editors</a><span class="post-meta-separator">,</span>
<a href="https://turfmagazine.com/business-management/evaluating-innovation-in-the-lawn-and-landscape-industry/" class="post-date" title="Permalink to Evaluating Innovation In The Lawn And Landscape Industry" rel="bookmark">June 17, 2022</a>
</div>
</div>
</article></li> </ul>
</div>
</li>
<li id="nav-menu-item-97842" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://turfmagazine.com/category/all-tree-services/" class="menu-link main-menu-link"><span>Tree Services <sup>®</sup></span></a><div class="sub-menu-container"> <ul class="sub-posts">
<li class="col-sm-4"><article class="post-106862 post-box post-box-large-thumbnail">
<div class="post-thumbnail-wrapper">
<a href="https://turfmagazine.com/all-tree-services/finding-emerald-ash-borer-watching-the-woodpeckers-and-early-id/" title="Permalink to Finding Emerald Ash Borer: Watching Woodpeckers &#038; Early ID" rel="bookmark">
<img width="360" height="200" src="https://turfmagazine.com/wp-content/uploads/2022/05/Unknown-360x200.jpeg" class="attachment-vw_small size-vw_small wp-post-image" alt="" loading="lazy" srcset="https://turfmagazine.com/wp-content/uploads/2022/05/Unknown-360x200.jpeg 360w, https://turfmagazine.com/wp-content/uploads/2022/05/Unknown-265x147.jpeg 265w" sizes="(max-width: 360px) 100vw, 360px" /> </a>
</div>
<div class="post-box-inner">
<h3 class="title"><a href="https://turfmagazine.com/all-tree-services/finding-emerald-ash-borer-watching-the-woodpeckers-and-early-id/" title="Permalink to Finding Emerald Ash Borer: Watching Woodpeckers &#038; Early ID" rel="bookmark">Finding Emerald Ash Borer: Watching Woodpeckers &#038; Early ID</a></h3>
<div class="post-meta header-font">
<img alt='' src='https://secure.gravatar.com/avatar/883b894c473d2403ac745d41928703d4?s=32&#038;r=r' srcset='https://secure.gravatar.com/avatar/883b894c473d2403ac745d41928703d4?s=64&#038;r=r 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy' /> <a class="author-name" href="https://turfmagazine.com/author/cmenapace/" title="View all posts by Christine Menapace">Christine Menapace</a><span class="post-meta-separator">,</span>
<a href="https://turfmagazine.com/all-tree-services/finding-emerald-ash-borer-watching-the-woodpeckers-and-early-id/" class="post-date" title="Permalink to Finding Emerald Ash Borer: Watching Woodpeckers &#038; Early ID" rel="bookmark">June 6, 2022</a>
</div>
</div>
</article></li><li class="col-sm-4"><article class="post-106644 post-box post-box-large-thumbnail">
<div class="post-thumbnail-wrapper">
<a href="https://turfmagazine.com/all-tree-services/bad-year-for-browntail-moth-infestations/" title="Permalink to Experts Predict Bad Year For Browntail Moth Infestations" rel="bookmark">
<img width="360" height="200" src="https://turfmagazine.com/wp-content/uploads/2022/05/BrowntailmothUGA5306007-360x200.jpg" class="attachment-vw_small size-vw_small wp-post-image" alt="browntail moth" loading="lazy" srcset="https://turfmagazine.com/wp-content/uploads/2022/05/BrowntailmothUGA5306007-360x200.jpg 360w, https://turfmagazine.com/wp-content/uploads/2022/05/BrowntailmothUGA5306007-265x147.jpg 265w" sizes="(max-width: 360px) 100vw, 360px" /> </a>
</div>
<div class="post-box-inner">
<h3 class="title"><a href="https://turfmagazine.com/all-tree-services/bad-year-for-browntail-moth-infestations/" title="Permalink to Experts Predict Bad Year For Browntail Moth Infestations" rel="bookmark">Experts Predict Bad Year For Browntail Moth Infestations</a></h3>
<div class="post-meta header-font">
<img alt='' src='https://secure.gravatar.com/avatar/883b894c473d2403ac745d41928703d4?s=32&#038;r=r' srcset='https://secure.gravatar.com/avatar/883b894c473d2403ac745d41928703d4?s=64&#038;r=r 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy' /> <a class="author-name" href="https://turfmagazine.com/author/cmenapace/" title="View all posts by Christine Menapace">Christine Menapace</a><span class="post-meta-separator">,</span>
<a href="https://turfmagazine.com/all-tree-services/bad-year-for-browntail-moth-infestations/" class="post-date" title="Permalink to Experts Predict Bad Year For Browntail Moth Infestations" rel="bookmark">May 9, 2022</a>
</div>
</div>
</article></li><li class="col-sm-4"><article class="post-106586 post-box post-box-large-thumbnail">
<div class="post-thumbnail-wrapper">
<a href="https://turfmagazine.com/all-tree-services/tough-trees-tree-selection-wind-salt-fire-risks/" title="Permalink to Tree Selection For Wind, Salt &#038; Fire Risks" rel="bookmark">
<img width="360" height="200" src="https://turfmagazine.com/wp-content/uploads/2022/05/TurfApr22-TS-Tough-Trees-Feature-360x200.jpg" class="attachment-vw_small size-vw_small wp-post-image" alt="Tree Selection" loading="lazy" srcset="https://turfmagazine.com/wp-content/uploads/2022/05/TurfApr22-TS-Tough-Trees-Feature-360x200.jpg 360w, https://turfmagazine.com/wp-content/uploads/2022/05/TurfApr22-TS-Tough-Trees-Feature-265x147.jpg 265w" sizes="(max-width: 360px) 100vw, 360px" /> </a>
</div>
<div class="post-box-inner">
<h3 class="title"><a href="https://turfmagazine.com/all-tree-services/tough-trees-tree-selection-wind-salt-fire-risks/" title="Permalink to Tree Selection For Wind, Salt &#038; Fire Risks" rel="bookmark">Tree Selection For Wind, Salt &#038; Fire Risks</a></h3>
<div class="post-meta header-font">
<img alt='' src='https://secure.gravatar.com/avatar/a2bd58988de28fb95eef5c074f376934?s=32&#038;r=r' srcset='https://secure.gravatar.com/avatar/a2bd58988de28fb95eef5c074f376934?s=64&#038;r=r 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy' /> <a class="author-name" href="https://turfmagazine.com/author/turf-editors/" title="View all posts by Turf Editors">Turf Editors</a><span class="post-meta-separator">,</span>
<a href="https://turfmagazine.com/all-tree-services/tough-trees-tree-selection-wind-salt-fire-risks/" class="post-date" title="Permalink to Tree Selection For Wind, Salt &#038; Fire Risks" rel="bookmark">May 3, 2022</a>
</div>
</div>
</article></li> </ul>
</div>
</li>
<li id="nav-menu-item-36396" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://turfmagazine.com/category/plow/" class="menu-link main-menu-link"><span>PLOW <sup>®</sup></span></a><div class="sub-menu-container"> <ul class="sub-posts">
<li class="col-sm-4"><article class="post-105496 post-box post-box-large-thumbnail">
<div class="post-thumbnail-wrapper">
<a href="https://turfmagazine.com/charitable-work/project-evergreen-snowcare-for-troops-awareness-week/" title="Permalink to Project EverGreen Highlights National SnowCare For Troops Awareness Week" rel="bookmark">
<img width="360" height="200" src="https://turfmagazine.com/wp-content/uploads/2022/01/project-evergreen-snow-ice-removal-360x200.jpeg" class="attachment-vw_small size-vw_small wp-post-image" alt="snow and ice removal" loading="lazy" srcset="https://turfmagazine.com/wp-content/uploads/2022/01/project-evergreen-snow-ice-removal-360x200.jpeg 360w, https://turfmagazine.com/wp-content/uploads/2022/01/project-evergreen-snow-ice-removal-265x147.jpeg 265w" sizes="(max-width: 360px) 100vw, 360px" /> </a>
</div>
<div class="post-box-inner">
<h3 class="title"><a href="https://turfmagazine.com/charitable-work/project-evergreen-snowcare-for-troops-awareness-week/" title="Permalink to Project EverGreen Highlights National SnowCare For Troops Awareness Week" rel="bookmark">Project EverGreen Highlights National SnowCare For Troops Awareness Week</a></h3>
<div class="post-meta header-font">
<img alt='' src='https://secure.gravatar.com/avatar/f82f7fc8048dfb859246b120ecf87b0e?s=32&#038;r=r' srcset='https://secure.gravatar.com/avatar/f82f7fc8048dfb859246b120ecf87b0e?s=64&#038;r=r 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy' /> <a class="author-name" href="https://turfmagazine.com/author/anne-cosgrove/" title="View all posts by Anne Cosgrove">Anne Cosgrove</a><span class="post-meta-separator">,</span>
<a href="https://turfmagazine.com/charitable-work/project-evergreen-snowcare-for-troops-awareness-week/" class="post-date" title="Permalink to Project EverGreen Highlights National SnowCare For Troops Awareness Week" rel="bookmark">January 24, 2022</a>
</div>
</div>
</article></li><li class="col-sm-4"><article class="post-104921 post-box post-box-large-thumbnail">
<div class="post-thumbnail-wrapper">
<a href="https://turfmagazine.com/plow/plow-insurance-that-kicks-in-only-when-you-need-it/" title="Permalink to Plow Insurance That Kicks In Only When You Need It?" rel="bookmark">
<img width="360" height="200" src="https://turfmagazine.com/wp-content/uploads/2021/11/hqdefault-360x200.jpg" class="attachment-vw_small size-vw_small wp-post-image" alt="insurance" loading="lazy" srcset="https://turfmagazine.com/wp-content/uploads/2021/11/hqdefault-360x200.jpg 360w, https://turfmagazine.com/wp-content/uploads/2021/11/hqdefault-265x147.jpg 265w" sizes="(max-width: 360px) 100vw, 360px" /> </a>
</div>
<div class="post-box-inner">
<h3 class="title"><a href="https://turfmagazine.com/plow/plow-insurance-that-kicks-in-only-when-you-need-it/" title="Permalink to Plow Insurance That Kicks In Only When You Need It?" rel="bookmark">Plow Insurance That Kicks In Only When You Need It?</a></h3>
<div class="post-meta header-font">
<img alt='' src='https://secure.gravatar.com/avatar/883b894c473d2403ac745d41928703d4?s=32&#038;r=r' srcset='https://secure.gravatar.com/avatar/883b894c473d2403ac745d41928703d4?s=64&#038;r=r 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy' /> <a class="author-name" href="https://turfmagazine.com/author/cmenapace/" title="View all posts by Christine Menapace">Christine Menapace</a><span class="post-meta-separator">,</span>
<a href="https://turfmagazine.com/plow/plow-insurance-that-kicks-in-only-when-you-need-it/" class="post-date" title="Permalink to Plow Insurance That Kicks In Only When You Need It?" rel="bookmark">December 2, 2021</a>
</div>
</div>
</article></li><li class="col-sm-4"><article class="post-105035 post-box post-box-large-thumbnail">
<div class="post-thumbnail-wrapper">
<a href="https://turfmagazine.com/plow/hitting-the-road-brine-beets-other-thanksgiving-treats/" title="Permalink to Hitting The Road: Brine, Beets &#038; Other Thanksgiving Treats" rel="bookmark">
<img width="360" height="200" src="https://turfmagazine.com/wp-content/uploads/2019/05/brineapp-360x200.jpg" class="attachment-vw_small size-vw_small wp-post-image" alt="rock salt" loading="lazy" srcset="https://turfmagazine.com/wp-content/uploads/2019/05/brineapp-360x200.jpg 360w, https://turfmagazine.com/wp-content/uploads/2019/05/brineapp-265x147.jpg 265w" sizes="(max-width: 360px) 100vw, 360px" /> </a>
</div>
<div class="post-box-inner">
<h3 class="title"><a href="https://turfmagazine.com/plow/hitting-the-road-brine-beets-other-thanksgiving-treats/" title="Permalink to Hitting The Road: Brine, Beets &#038; Other Thanksgiving Treats" rel="bookmark">Hitting The Road: Brine, Beets &#038; Other Thanksgiving Treats</a></h3>
<div class="post-meta header-font">
<img alt='' src='https://secure.gravatar.com/avatar/883b894c473d2403ac745d41928703d4?s=32&#038;r=r' srcset='https://secure.gravatar.com/avatar/883b894c473d2403ac745d41928703d4?s=64&#038;r=r 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy' /> <a class="author-name" href="https://turfmagazine.com/author/cmenapace/" title="View all posts by Christine Menapace">Christine Menapace</a><span class="post-meta-separator">,</span>
<a href="https://turfmagazine.com/plow/hitting-the-road-brine-beets-other-thanksgiving-treats/" class="post-date" title="Permalink to Hitting The Road: Brine, Beets &#038; Other Thanksgiving Treats" rel="bookmark">November 24, 2021</a>
</div>
</div>
</article></li> </ul>
</div>
</li>
<li id="nav-menu-item-97843" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent"><a href="https://turfmagazine.com/category/tdb/" class="menu-link main-menu-link"><span>Turf Design Build <sup>®</sup></span></a><div class="sub-menu-container"> <ul class="sub-posts">
<li class="col-sm-4"><article class="post-107029 post-box post-box-large-thumbnail">
<div class="post-thumbnail-wrapper">
<a href="https://turfmagazine.com/tdb/stihl-sponsors-philadelphia-flower-show-highlighting-innovative-landscapers/" title="Permalink to STIHL Sponsors Philadelphia Flower Show Highlighting Innovative Landscapers" rel="bookmark">
<img width="360" height="200" src="https://turfmagazine.com/wp-content/uploads/2022/06/cl4bkwgbl4l1x8crawehlz49e-rcardillo-markcook.0.0.8256.5504.full_-360x200.jpg" class="attachment-vw_small size-vw_small wp-post-image" alt="" loading="lazy" srcset="https://turfmagazine.com/wp-content/uploads/2022/06/cl4bkwgbl4l1x8crawehlz49e-rcardillo-markcook.0.0.8256.5504.full_-360x200.jpg 360w, https://turfmagazine.com/wp-content/uploads/2022/06/cl4bkwgbl4l1x8crawehlz49e-rcardillo-markcook.0.0.8256.5504.full_-265x147.jpg 265w" sizes="(max-width: 360px) 100vw, 360px" /> </a>
</div>
<div class="post-box-inner">
<h3 class="title"><a href="https://turfmagazine.com/tdb/stihl-sponsors-philadelphia-flower-show-highlighting-innovative-landscapers/" title="Permalink to STIHL Sponsors Philadelphia Flower Show Highlighting Innovative Landscapers" rel="bookmark">STIHL Sponsors Philadelphia Flower Show Highlighting Innovative Landscapers</a></h3>
<div class="post-meta header-font">
<img alt='' src='https://secure.gravatar.com/avatar/883b894c473d2403ac745d41928703d4?s=32&#038;r=r' srcset='https://secure.gravatar.com/avatar/883b894c473d2403ac745d41928703d4?s=64&#038;r=r 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy' /> <a class="author-name" href="https://turfmagazine.com/author/cmenapace/" title="View all posts by Christine Menapace">Christine Menapace</a><span class="post-meta-separator">,</span>
<a href="https://turfmagazine.com/tdb/stihl-sponsors-philadelphia-flower-show-highlighting-innovative-landscapers/" class="post-date" title="Permalink to STIHL Sponsors Philadelphia Flower Show Highlighting Innovative Landscapers" rel="bookmark">June 24, 2022</a>
</div>
</div>
</article></li><li class="col-sm-4"><article class="post-106659 post-box post-box-large-thumbnail">
<div class="post-thumbnail-wrapper">
<a href="https://turfmagazine.com/tdb/secretary-haaland-announces-61-million-to-increase-outdoor-opportunities-in-urban-areas/" title="Permalink to Secretary Haaland Announces $61 Million to Increase Outdoor Opportunities in Urban Areas" rel="bookmark">
<img width="360" height="200" src="https://turfmagazine.com/wp-content/uploads/2022/05/MN-2-360x200.jpg" class="attachment-vw_small size-vw_small wp-post-image" alt="Secretary Haaland" loading="lazy" srcset="https://turfmagazine.com/wp-content/uploads/2022/05/MN-2-360x200.jpg 360w, https://turfmagazine.com/wp-content/uploads/2022/05/MN-2-265x147.jpg 265w" sizes="(max-width: 360px) 100vw, 360px" /> </a>
</div>
<div class="post-box-inner">
<h3 class="title"><a href="https://turfmagazine.com/tdb/secretary-haaland-announces-61-million-to-increase-outdoor-opportunities-in-urban-areas/" title="Permalink to Secretary Haaland Announces $61 Million to Increase Outdoor Opportunities in Urban Areas" rel="bookmark">Secretary Haaland Announces $61 Million to Increase Outdoor Opportunities in Urban Areas</a></h3>
<div class="post-meta header-font">
<img alt='' src='https://secure.gravatar.com/avatar/edb1283861b8dfeca9b1ff1e1f3f2121?s=32&#038;r=r' srcset='https://secure.gravatar.com/avatar/edb1283861b8dfeca9b1ff1e1f3f2121?s=64&#038;r=r 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy' /> <a class="author-name" href="https://turfmagazine.com/author/jschwartz/" title="View all posts by Jessica Schwartz">Jessica Schwartz</a><span class="post-meta-separator">,</span>
<a href="https://turfmagazine.com/tdb/secretary-haaland-announces-61-million-to-increase-outdoor-opportunities-in-urban-areas/" class="post-date" title="Permalink to Secretary Haaland Announces $61 Million to Increase Outdoor Opportunities in Urban Areas" rel="bookmark">May 17, 2022</a>
</div>
</div>
</article></li><li class="col-sm-4"><article class="post-106536 post-box post-box-large-thumbnail">
<div class="post-thumbnail-wrapper">
<a href="https://turfmagazine.com/tdb/own-it-low-monthly-payment-program-unveiled-by-john-deere/" title="Permalink to “Own It” Low Monthly Payment Program Unveiled By John Deere" rel="bookmark">
<img width="360" height="200" src="https://turfmagazine.com/wp-content/uploads/2022/05/John-Deere-LMP-2022-360x200.jpg" class="attachment-vw_small size-vw_small wp-post-image" alt="own it" loading="lazy" srcset="https://turfmagazine.com/wp-content/uploads/2022/05/John-Deere-LMP-2022-360x200.jpg 360w, https://turfmagazine.com/wp-content/uploads/2022/05/John-Deere-LMP-2022-265x147.jpg 265w" sizes="(max-width: 360px) 100vw, 360px" /> </a>
</div>
<div class="post-box-inner">
<h3 class="title"><a href="https://turfmagazine.com/tdb/own-it-low-monthly-payment-program-unveiled-by-john-deere/" title="Permalink to “Own It” Low Monthly Payment Program Unveiled By John Deere" rel="bookmark">“Own It” Low Monthly Payment Program Unveiled By John Deere</a></h3>
<div class="post-meta header-font">
<img alt='' src='https://secure.gravatar.com/avatar/edb1283861b8dfeca9b1ff1e1f3f2121?s=32&#038;r=r' srcset='https://secure.gravatar.com/avatar/edb1283861b8dfeca9b1ff1e1f3f2121?s=64&#038;r=r 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy' /> <a class="author-name" href="https://turfmagazine.com/author/jschwartz/" title="View all posts by Jessica Schwartz">Jessica Schwartz</a><span class="post-meta-separator">,</span>
<a href="https://turfmagazine.com/tdb/own-it-low-monthly-payment-program-unveiled-by-john-deere/" class="post-date" title="Permalink to “Own It” Low Monthly Payment Program Unveiled By John Deere" rel="bookmark">May 10, 2022</a>
</div>
</div>
</article></li> </ul>
</div>
</li>
<li id="nav-menu-item-95655" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="https://turfmagazine.com/category/turfmagazine/" class="menu-link main-menu-link"><span>Magazine</span></a><div class="sub-menu-container">
<ul class="sub-menu menu-odd  menu-depth-1">
<li id="nav-menu-item-95656" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://turfmagazine.com/category/turfmagazine/business-management-editorial/" class="menu-link sub-menu-link"><span>Business Management</span></a></li>
<li id="nav-menu-item-95657" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://turfmagazine.com/category/turfmagazine/contractor-profiles-editorial/" class="menu-link sub-menu-link"><span>Contractor Profiles</span></a></li>
<li id="nav-menu-item-95658" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://turfmagazine.com/category/turfmagazine/cover-story/" class="menu-link sub-menu-link"><span>Cover Story</span></a></li>
<li id="nav-menu-item-103643" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://turfmagazine.com/category/turfmagazine/get-equipped/" class="menu-link sub-menu-link"><span>Get Equipped</span></a></li>
<li id="nav-menu-item-95659" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://turfmagazine.com/category/turfmagazine/hardscapes-editorial/" class="menu-link sub-menu-link"><span>Hardscapes</span></a></li>
<li id="nav-menu-item-95660" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://turfmagazine.com/category/turfmagazine/my-landscape/" class="menu-link sub-menu-link"><span>My Landscape</span></a></li>
<li id="nav-menu-item-95661" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://turfmagazine.com/category/turfmagazine/operations-and-services/" class="menu-link sub-menu-link"><span>Operations &#038; Services</span></a></li>
<li id="nav-menu-item-95662" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://turfmagazine.com/category/turfmagazine/snow-ice-management-editorial/" class="menu-link sub-menu-link"><span>Snow &#038; Ice Management</span></a></li>
<li id="nav-menu-item-95663" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://turfmagazine.com/category/turfmagazine/tree-care-editorial/" class="menu-link sub-menu-link"><span>Tree Care</span></a></li>
<li id="nav-menu-item-95664" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://turfmagazine.com/category/turfmagazine/turf-and-ornamentals/" class="menu-link sub-menu-link"><span>Turf &#038; Ornamentals</span></a></li>
</ul>
<ul class="sub-posts">
<li class="col-sm-4"><article class="post-106735 post-box post-box-large-thumbnail">
<div class="post-thumbnail-wrapper">
<a href="https://turfmagazine.com/the-latest/mission-unstoppable-women-in-trees/" title="Permalink to Mission Unstoppable: Women In Trees" rel="bookmark">
<img width="360" height="200" src="https://turfmagazine.com/wp-content/uploads/2022/05/WTCW.crop_-360x200.jpg" class="attachment-vw_small size-vw_small wp-post-image" alt="Women’s Tree Climbing Workshop" loading="lazy" srcset="https://turfmagazine.com/wp-content/uploads/2022/05/WTCW.crop_-360x200.jpg 360w, https://turfmagazine.com/wp-content/uploads/2022/05/WTCW.crop_-265x147.jpg 265w" sizes="(max-width: 360px) 100vw, 360px" /> </a>
</div>
<div class="post-box-inner">
<h3 class="title"><a href="https://turfmagazine.com/the-latest/mission-unstoppable-women-in-trees/" title="Permalink to Mission Unstoppable: Women In Trees" rel="bookmark">Mission Unstoppable: Women In Trees</a></h3>
<div class="post-meta header-font">
<img alt='' src='https://secure.gravatar.com/avatar/a2bd58988de28fb95eef5c074f376934?s=32&#038;r=r' srcset='https://secure.gravatar.com/avatar/a2bd58988de28fb95eef5c074f376934?s=64&#038;r=r 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy' /> <a class="author-name" href="https://turfmagazine.com/author/turf-editors/" title="View all posts by Turf Editors">Turf Editors</a><span class="post-meta-separator">,</span>
<a href="https://turfmagazine.com/the-latest/mission-unstoppable-women-in-trees/" class="post-date" title="Permalink to Mission Unstoppable: Women In Trees" rel="bookmark">May 13, 2022</a>
</div>
</div>
</article></li><li class="col-sm-4"><article class="post-106702 post-box post-box-large-thumbnail">
<div class="post-thumbnail-wrapper">
<a href="https://turfmagazine.com/turfmagazine/my-landscape/ut-turf-manager-co-invents-solar-charging-solution-robotic-mowers/" title="Permalink to UT Turf Manager Co-Invents Solar Charging Solution For Robotic Mowers" rel="bookmark">
<img width="360" height="200" src="https://turfmagazine.com/wp-content/uploads/2022/05/TurfApr22-MyLandscape-Feature-360x200.jpg" class="attachment-vw_small size-vw_small wp-post-image" alt="Powershed" loading="lazy" srcset="https://turfmagazine.com/wp-content/uploads/2022/05/TurfApr22-MyLandscape-Feature-360x200.jpg 360w, https://turfmagazine.com/wp-content/uploads/2022/05/TurfApr22-MyLandscape-Feature-265x147.jpg 265w" sizes="(max-width: 360px) 100vw, 360px" /> </a>
</div>
<div class="post-box-inner">
<h3 class="title"><a href="https://turfmagazine.com/turfmagazine/my-landscape/ut-turf-manager-co-invents-solar-charging-solution-robotic-mowers/" title="Permalink to UT Turf Manager Co-Invents Solar Charging Solution For Robotic Mowers" rel="bookmark">UT Turf Manager Co-Invents Solar Charging Solution For Robotic Mowers</a></h3>
<div class="post-meta header-font">
<img alt='' src='https://secure.gravatar.com/avatar/a2bd58988de28fb95eef5c074f376934?s=32&#038;r=r' srcset='https://secure.gravatar.com/avatar/a2bd58988de28fb95eef5c074f376934?s=64&#038;r=r 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy' /> <a class="author-name" href="https://turfmagazine.com/author/turf-editors/" title="View all posts by Turf Editors">Turf Editors</a><span class="post-meta-separator">,</span>
<a href="https://turfmagazine.com/turfmagazine/my-landscape/ut-turf-manager-co-invents-solar-charging-solution-robotic-mowers/" class="post-date" title="Permalink to UT Turf Manager Co-Invents Solar Charging Solution For Robotic Mowers" rel="bookmark">May 11, 2022</a>
</div>
</div>
</article></li><li class="col-sm-4"><article class="post-106657 post-box post-box-large-thumbnail">
<div class="post-thumbnail-wrapper">
<a href="https://turfmagazine.com/turfmagazine/feature/soil-sustainability-yard-waste-recycling/" title="Permalink to Soil Sustainability: Yard Waste Recycling" rel="bookmark">
<img width="360" height="200" src="https://turfmagazine.com/wp-content/uploads/2022/05/TurfApr22-SoilSustainability-Feature-360x200.jpg" class="attachment-vw_small size-vw_small wp-post-image" alt="Yard Waste Recycling" loading="lazy" srcset="https://turfmagazine.com/wp-content/uploads/2022/05/TurfApr22-SoilSustainability-Feature-360x200.jpg 360w, https://turfmagazine.com/wp-content/uploads/2022/05/TurfApr22-SoilSustainability-Feature-265x147.jpg 265w" sizes="(max-width: 360px) 100vw, 360px" /> </a>
</div>
<div class="post-box-inner">
<h3 class="title"><a href="https://turfmagazine.com/turfmagazine/feature/soil-sustainability-yard-waste-recycling/" title="Permalink to Soil Sustainability: Yard Waste Recycling" rel="bookmark">Soil Sustainability: Yard Waste Recycling</a></h3>
<div class="post-meta header-font">
<img alt='' src='https://secure.gravatar.com/avatar/670b0d8e3699bd112f9661f96fc39862?s=32&#038;r=r' srcset='https://secure.gravatar.com/avatar/670b0d8e3699bd112f9661f96fc39862?s=64&#038;r=r 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy' /> <a class="author-name" href="https://turfmagazine.com/author/jenna-mcallister/" title="View all posts by Jenna McAllister">Jenna McAllister</a><span class="post-meta-separator">,</span>
<a href="https://turfmagazine.com/turfmagazine/feature/soil-sustainability-yard-waste-recycling/" class="post-date" title="Permalink to Soil Sustainability: Yard Waste Recycling" rel="bookmark">May 10, 2022</a>
</div>
</div>
</article></li> </ul>
</div>
</li>
</ul></nav> </div>
</div>
</div>
</div>


<center>
<div id="div-gpt-ad-1467129242315-15">
<script type="text/javascript">
googletag.cmd.push(function() {
googletag.display("div-gpt-ad-1467129242315-15");
});
</script>
</div>
</center>

<div id="div-gpt-ad-1467129242315-3">
<script type="text/javascript">
googletag.cmd.push(function(){
googletag.display("div-gpt-ad-1467129242315-3");
});
</script>
</div>
<div id="page-wrapper" class="container">
<div class="row">
<div id="page-content" class="col-sm-7 col-md-8">
<article id="post-107029" class="post-107029 post type-post status-publish format-standard has-post-thumbnail hentry category-contractor-profiles category-landscape-designbuildinstallation category-industry-news category-innovation category-manufacturersupplier-updates category-nurseryplant-materials category-the-latest category-tdb tag-award-winning-landscapers tag-innovative-landscape-design tag-irwin-landscaping tag-jeff-cartwright tag-mark-cook-landscape-contracting tag-philadelphia-flower-show tag-refugia-design tag-sara-bendrick tag-stihl tag-susan-cohan-gardens">
<div class="tags clearfix">
<a class="label " href="https://turfmagazine.com/category/contractor-profiles/" title="View all posts in Contractor Profiles" rel="category">Contractor Profiles</a><a class="label " href="https://turfmagazine.com/category/landscape-designbuildinstallation/" title="View all posts in Design, Build &amp; Installation" rel="category">Design, Build &amp; Installation</a><a class="label " href="https://turfmagazine.com/category/industry-news/" title="View all posts in Industry News" rel="category">Industry News</a><a class="label " href="https://turfmagazine.com/category/innovation/" title="View all posts in Innovation" rel="category">Innovation</a><a class="label " href="https://turfmagazine.com/category/manufacturersupplier-updates/" title="View all posts in Manufacturer/Supplier Updates" rel="category">Manufacturer/Supplier Updates</a><a class="label " href="https://turfmagazine.com/category/nurseryplant-materials/" title="View all posts in Plants" rel="category">Plants</a><a class="label " href="https://turfmagazine.com/category/the-latest/" title="View all posts in The Latest" rel="category">The Latest</a><a class="label " href="https://turfmagazine.com/category/tdb/" title="View all posts in Turf Design Build" rel="category">Turf Design Build</a> </div>
<h1 class="post-title title title-large entry-title">STIHL Sponsors Philadelphia Flower Show Highlighting Innovative Landscapers</h1>
<hr class="hr-thin-bottom">
<div class="social-share">
<span class="header-font">SHARE ON:</span>
<a class="social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fturfmagazine.com%2Ftdb%2Fstihl-sponsors-philadelphia-flower-show-highlighting-innovative-landscapers%2F&amp;t=STIHL Sponsors Philadelphia Flower Show Highlighting Innovative Landscapers" title="Share on Facebook" target="_blank"><i class="icon-social-facebook"></i></a>
<a class="social-twitter" href="https://twitter.com/home?status=STIHL Sponsors Philadelphia Flower Show Highlighting Innovative Landscapers https://turfmagazine.com/tdb/stihl-sponsors-philadelphia-flower-show-highlighting-innovative-landscapers/" title="Share on Twitter" target="_blank"><i class="icon-social-twitter"></i></a>
<a class="social-pinterest" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fturfmagazine.com%2Ftdb%2Fstihl-sponsors-philadelphia-flower-show-highlighting-innovative-landscapers%2F&amp;media=https://turfmagazine.com/wp-content/uploads/2022/06/cl4bkwgbl4l1x8crawehlz49e-rcardillo-markcook.0.0.8256.5504.full_.jpg&amp;description=STIHL Sponsors Philadelphia Flower Show Highlighting Innovative Landscapers" title="Share on Pinterest" target="_blank"><i class="icon-social-pinterest"></i></a>
</div>
<div class="post-meta header-font">
<a href="https://turfmagazine.com/author/cmenapace/" title="Posts by Christine Menapace" class="author url fn" rel="author">Christine Menapace</a>
<span class="post-meta-separator">&mdash;</span> <a href="https://turfmagazine.com/tdb/stihl-sponsors-philadelphia-flower-show-highlighting-innovative-landscapers/" class="post-date updated" title="Permalink to STIHL Sponsors Philadelphia Flower Show Highlighting Innovative Landscapers" rel="bookmark">June 24, 2022</a>
</div>
<div class="post-content clearfix">

<div class="tdb-logo brand-logo"><h4>Brought to you by</h4><a href="https://www.turfmagazine.com/category/turf-design-build/"><img width="612" height="192" style="width:300px; height:auto;" src="/wp-content/uploads/2020/04/TDBLogogRegisterMark.jpg" /></a></div> 
<div class="pdfprnt-buttons pdfprnt-buttons-post pdfprnt-top-right"><a href="javascript: imageToPdf()" class="pdfprnt-button pdfprnt-button-pdf" target="_self" rel="nofollow"><img src="https://turfmagazine.com/wp-content/uploads/pdf-print-buttons/pdf_button.png?390557606" alt="image_pdf" title="Download PDF" /></a><a href="https://turfmagazine.com/tdb/stihl-sponsors-philadelphia-flower-show-highlighting-innovative-landscapers/?print=print" class="pdfprnt-button pdfprnt-button-print" target="_blank" rel="nofollow"></a></div><p><img loading="lazy" class="aligncenter size-full wp-image-107030" src="https://turfmagazine.com/wp-content/uploads/2022/06/Image-from-iOS-15.jpg" alt="Flower Show" width="766" height="504" srcset="https://turfmagazine.com/wp-content/uploads/2022/06/Image-from-iOS-15.jpg 766w, https://turfmagazine.com/wp-content/uploads/2022/06/Image-from-iOS-15-456x300.jpg 456w" sizes="(max-width: 766px) 100vw, 766px" /></p>
<p>This year, STIHL was an official sponsor for the annual 2022 PHS Philadelphia Flower Show. From June 11 through June 19, the nation’s largest and longest-running horticultural event, the PHS Philadelphia Flower Show, attracted hundreds of guests with its extravagant displays and educational look at horticulture with the theme, “In Full Bloom.”</p>
<p>STIHL had a booth at the show, bringing along Team STIHL spokespersons’ contracted landscaper <a href="https://www.stihlusa.com/community/team-stihl/sara-bendrick/">Sara Bendrick</a> and landscape business owner <a href="https://www.stihlusa.com/community/team-stihl/jeff-cartwright/">Jeff Cartwright</a> to join the fun. With breakout sessions during the event, Cartwright shared best practices for growing grass while Bendrick provided soil tips to the garden enthusiasts.</p>
<h3>Award Winners</h3>
<div id="attachment_107031" style="width: 770px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-107031" loading="lazy" class="size-full wp-image-107031" src="https://turfmagazine.com/wp-content/uploads/2022/06/cl4bkwgbl4l1x8crawehlz49e-rcardillo-markcook.0.0.8256.5504.full_.jpg" alt="Flower Show" width="770" height="513" srcset="https://turfmagazine.com/wp-content/uploads/2022/06/cl4bkwgbl4l1x8crawehlz49e-rcardillo-markcook.0.0.8256.5504.full_.jpg 770w, https://turfmagazine.com/wp-content/uploads/2022/06/cl4bkwgbl4l1x8crawehlz49e-rcardillo-markcook.0.0.8256.5504.full_-450x300.jpg 450w, https://turfmagazine.com/wp-content/uploads/2022/06/cl4bkwgbl4l1x8crawehlz49e-rcardillo-markcook.0.0.8256.5504.full_-768x512.jpg 768w" sizes="(max-width: 770px) 100vw, 770px" /><p id="caption-attachment-107031" class="wp-caption-text">Mark Cook Landscapes &amp; Contracting LLC won Best in Show.</p></div>
<p>&nbsp;</p>
<p>The sought-after “PHS Philadelphia Flower Show Cup &#8211; Best in Show” award was presented to Mark Cook Landscape &amp; Contracting LLC for its excellent representation of theme and garden design. Mark Cook, the owner of <a href="http://www.mclcdesign.com">Mark Cook Landscape &amp; Contracting</a>, is known for his innovative designs which have won him various awards in each Philadelphia Flower Show over the last 11 years, including Best in Show in 2020 and 2017, and the Silver Trophy in 2014, 2018, and 2019.</p>
<p>The Silver Trophy was awarded to <a href="https://www.susancohangardens.com">Susan Cohan Gardens</a>, who created a peaceful and beautiful space meant to encourage visitors to reflect and dream, inspired by Virginia Woolf’s essay, “A Room of One’s Own.”</p>
<p>The Governor’s Trophy was awarded to <a href="https://www.refugiadesign.com">Refugia Design</a>, who designed its exhibit to be alive with sights, sounds, and smells and featured native plants, sustainable materials, and innovative soundscapes.</p>
<p>The Kate and Robert Bartlett, Jr. Award for Best Use of Trees (Landscape) went to <a href="https://www.irwinlandscaping.com">Irwin Landscaping</a>.</p>
<p>The Philadelphia Trophy was awarded to Auburn University Landscape Architecture Program with “Conquer the Soil,” whose striking exhibit made use of color, depth, and perspective.</p>
<p>The 2022 Flower Show is the second time the Show was held outdoors in its almost 200-year history.</p>
<p><strong>To see <em>Turf&#8217;s</em> highlights of the 2021 Show, <a href="https://turfmagazine.com/tdb/landscape-design-from-the-philadelphia-flower-show/">click here</a>.</strong></p>
<p>&nbsp;</p>
</div>
<div class="post-tags clearfix">
<span class="post-tags-title header-font">Tags:</span> <a class="label label-small label-light" href="https://turfmagazine.com/tag/award-winning-landscapers/" title="View all posts in Award Winning Landscapers" rel="category">Award Winning Landscapers</a><a class="label label-small label-light" href="https://turfmagazine.com/tag/innovative-landscape-design/" title="View all posts in Innovative Landscape Design" rel="category">Innovative Landscape Design</a><a class="label label-small label-light" href="https://turfmagazine.com/tag/irwin-landscaping/" title="View all posts in Irwin Landscaping" rel="category">Irwin Landscaping</a><a class="label label-small label-light" href="https://turfmagazine.com/tag/jeff-cartwright/" title="View all posts in Jeff Cartwright" rel="category">Jeff Cartwright</a><a class="label label-small label-light" href="https://turfmagazine.com/tag/mark-cook-landscape-contracting/" title="View all posts in Mark Cook Landscape &amp; Contracting" rel="category">Mark Cook Landscape &amp; Contracting</a><a class="label label-small label-light" href="https://turfmagazine.com/tag/philadelphia-flower-show/" title="View all posts in Philadelphia Flower Show" rel="category">Philadelphia Flower Show</a><a class="label label-small label-light" href="https://turfmagazine.com/tag/refugia-design/" title="View all posts in Refugia Design" rel="category">Refugia Design</a><a class="label label-small label-light" href="https://turfmagazine.com/tag/sara-bendrick/" title="View all posts in Sara Bendrick" rel="category">Sara Bendrick</a><a class="label label-small label-light" href="https://turfmagazine.com/tag/stihl/" title="View all posts in STIHL" rel="category">STIHL</a><a class="label label-small label-light" href="https://turfmagazine.com/tag/susan-cohan-gardens/" title="View all posts in Susan Cohan Gardens" rel="category">Susan Cohan Gardens</a> </div>
</article>
<div class="post-nav section-container clearfix">
<a class="post-previous" href="https://turfmagazine.com/safety/national-hydration-day-the-most-effective-outdoor-work-drink-options/">
<i class="icon-entypo-left-open-big"></i>
<h3 class="title title-small">
<span class="super-title">Previous post</span>
National Hydration Day: The Most Effective Outdoor Work Drink Options </h3>
</a>
</div>
<div class="about-author section-container clearfix vcard author">
<img alt='Christine Menapace' src='https://secure.gravatar.com/avatar/883b894c473d2403ac745d41928703d4?s=200&#038;r=r' srcset='https://secure.gravatar.com/avatar/883b894c473d2403ac745d41928703d4?s=400&#038;r=r 2x' class='avatar avatar-200 photo' height='200' width='200' loading='lazy' />
<div class="about-author-info">
<h3 class="author-name title title-medium">
<span class="super-title">About the Author</span>
<span class="fn">Christine Menapace</span>
</h3>
<div class="author-bio"></div>
<div class="author-socials">
</div>
</div>
</div>
<div class="post-related section-container clearfix">
<h2 class="section-title">Related Posts</h2>
<div class="row">
<div class="post-box-wrapper col-sm-6 col-md-4 ">
<article class="post-106890 post-box post-box-headline">
<h3 class="title title-small"><a href="https://turfmagazine.com/manufacturersupplier-updates/stihl-and-briggs-stratton-announce-new-manufacturing-relationship/" title="Permalink to STIHL and Briggs &#038; Stratton Announce New Manufacturing Relationship" rel="bookmark">STIHL and Briggs &#038; Stratton Announce New Manufacturing Relationship</a></h3>
<div class="post-meta header-font">
<img alt='' src='https://secure.gravatar.com/avatar/edb1283861b8dfeca9b1ff1e1f3f2121?s=32&#038;r=r' srcset='https://secure.gravatar.com/avatar/edb1283861b8dfeca9b1ff1e1f3f2121?s=64&#038;r=r 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy' /> <a class="author-name" href="https://turfmagazine.com/author/jschwartz/" title="View all posts by Jessica Schwartz">Jessica Schwartz</a><span class="post-meta-separator">,</span>
<a href="https://turfmagazine.com/manufacturersupplier-updates/stihl-and-briggs-stratton-announce-new-manufacturing-relationship/" class="post-date" title="Permalink to STIHL and Briggs &#038; Stratton Announce New Manufacturing Relationship" rel="bookmark">June 9, 2022</a>
</div>
<div class="post-thumbnail-wrapper vw-imgliquid">
<a href="https://turfmagazine.com/manufacturersupplier-updates/stihl-and-briggs-stratton-announce-new-manufacturing-relationship/" title="Permalink to STIHL and Briggs &#038; Stratton Announce New Manufacturing Relationship" rel="bookmark">
<img width="360" height="200" src="https://turfmagazine.com/wp-content/uploads/2022/06/Screenshot-2022-06-01-10.25.38-AM-360x200.png" class="attachment-vw_small size-vw_small wp-post-image" alt="STIHL Briggs Stratton" loading="lazy" srcset="https://turfmagazine.com/wp-content/uploads/2022/06/Screenshot-2022-06-01-10.25.38-AM-360x200.png 360w, https://turfmagazine.com/wp-content/uploads/2022/06/Screenshot-2022-06-01-10.25.38-AM-265x147.png 265w" sizes="(max-width: 360px) 100vw, 360px" /> </a>
</div>
</article> </div>
<div class="post-box-wrapper col-sm-6 col-md-4 ">
<article class="post-106294 post-box post-box-headline">
<h3 class="title title-small"><a href="https://turfmagazine.com/manufacturersupplier-updates/stihl-launches-made-in-america-campaign/" title="Permalink to STIHL Launches &#8220;Made In America&#8221; Campaign" rel="bookmark">STIHL Launches &#8220;Made In America&#8221; Campaign</a></h3>
<div class="post-meta header-font">
<img alt='' src='https://secure.gravatar.com/avatar/edb1283861b8dfeca9b1ff1e1f3f2121?s=32&#038;r=r' srcset='https://secure.gravatar.com/avatar/edb1283861b8dfeca9b1ff1e1f3f2121?s=64&#038;r=r 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy' /> <a class="author-name" href="https://turfmagazine.com/author/jschwartz/" title="View all posts by Jessica Schwartz">Jessica Schwartz</a><span class="post-meta-separator">,</span>
<a href="https://turfmagazine.com/manufacturersupplier-updates/stihl-launches-made-in-america-campaign/" class="post-date" title="Permalink to STIHL Launches &#8220;Made In America&#8221; Campaign" rel="bookmark">May 12, 2022</a>
</div>
<div class="post-thumbnail-wrapper vw-imgliquid">
<a href="https://turfmagazine.com/manufacturersupplier-updates/stihl-launches-made-in-america-campaign/" title="Permalink to STIHL Launches &#8220;Made In America&#8221; Campaign" rel="bookmark">
<img width="360" height="200" src="https://turfmagazine.com/wp-content/uploads/2022/04/219df503-b978-4929-8b13-0f0fc7ac9884-360x200.jpg" class="attachment-vw_small size-vw_small wp-post-image" alt="MIA" loading="lazy" srcset="https://turfmagazine.com/wp-content/uploads/2022/04/219df503-b978-4929-8b13-0f0fc7ac9884-360x200.jpg 360w, https://turfmagazine.com/wp-content/uploads/2022/04/219df503-b978-4929-8b13-0f0fc7ac9884-265x147.jpg 265w" sizes="(max-width: 360px) 100vw, 360px" /> </a>
</div>
</article> </div>
<div class="post-box-wrapper col-sm-6 col-md-4 hidden-sm">
<article class="post-106509 post-box post-box-headline">
<h3 class="title title-small"><a href="https://turfmagazine.com/charitable-work/hearts-of-stihl-award/" title="Permalink to Hearts of STIHL To Award 6 State Parks $20,000 Each" rel="bookmark">Hearts of STIHL To Award 6 State Parks $20,000 Each</a></h3>
<div class="post-meta header-font">
<img alt='' src='https://secure.gravatar.com/avatar/883b894c473d2403ac745d41928703d4?s=32&#038;r=r' srcset='https://secure.gravatar.com/avatar/883b894c473d2403ac745d41928703d4?s=64&#038;r=r 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy' /> <a class="author-name" href="https://turfmagazine.com/author/cmenapace/" title="View all posts by Christine Menapace">Christine Menapace</a><span class="post-meta-separator">,</span>
<a href="https://turfmagazine.com/charitable-work/hearts-of-stihl-award/" class="post-date" title="Permalink to Hearts of STIHL To Award 6 State Parks $20,000 Each" rel="bookmark">May 3, 2022</a>
</div>
<div class="post-thumbnail-wrapper vw-imgliquid">
<a href="https://turfmagazine.com/charitable-work/hearts-of-stihl-award/" title="Permalink to Hearts of STIHL To Award 6 State Parks $20,000 Each" rel="bookmark">
<img width="360" height="200" src="https://turfmagazine.com/wp-content/uploads/2022/04/4c095952-c2ed-4f25-8aad-51d40d4dfbef-360x200.jpg" class="attachment-vw_small size-vw_small wp-post-image" alt="Hearts" loading="lazy" srcset="https://turfmagazine.com/wp-content/uploads/2022/04/4c095952-c2ed-4f25-8aad-51d40d4dfbef-360x200.jpg 360w, https://turfmagazine.com/wp-content/uploads/2022/04/4c095952-c2ed-4f25-8aad-51d40d4dfbef-265x147.jpg 265w" sizes="(max-width: 360px) 100vw, 360px" /> </a>
</div>
</article> </div>
</div>
</div>
<div id="comments" class="section-container clearfix">
<h3 class="section-title">No Comment</h3>
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/tdb/stihl-sponsors-philadelphia-flower-show-highlighting-innovative-landscapers/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://turfmagazine.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><div id="respond-textarea"><p><textarea id="comment" name="comment" aria-required="true" cols="58" rows="10" tabindex="4"></textarea></p></div><div id="respond-inputs" class="clearfix"><p><input name="author" type="text" placeholder="Name (required)" size="30" aria-required='true' /></p>
<p><input name="email" type="text" placeholder="E-Mail (required)" size="30" aria-required='true' /></p>
<p class="last"><input name="url" type="text" placeholder="Website" size="30" /></p></div>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Submit comment" /> <input type='hidden' name='comment_post_ID' value='107029' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="ce73112e72" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="212" /><script type="rocketlazyloadscript">document.getElementById( "ak_js_1" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form> </div>
</div>
</div>
<aside id="page-sidebar" class="sidebar-wrapper col-sm-5 col-md-4">
<div class="sidebar-inner">
<div id="search-5" class="widget vw-sidebar-custom-Content-Sidebar widget_search"><form action="https://turfmagazine.com/" id="searchform" class="searchform" method="get">
<input type="text" id="s" name="s" value="Search" onfocus="if(this.value=='Search')this.value='';" onblur="if(this.value=='')this.value='Search';" autocomplete="off" />
<button class="search-button"><i class="icon-entypo-search"></i></button>
</form></div><div id="custom_html-8" class="widget_text widget vw-sidebar-custom-Content-Sidebar widget_custom_html"><div class="textwidget custom-html-widget">
<center>
<div id="div-gpt-ad-1467129242315-5">
<script type="text/javascript">
 googletag.cmd.push(function(){
googletag.display("div-gpt-ad-1467129242315-5");
});
</script>
</div>
</center></div></div><div id="vw_widget_latest_category-6" class="widget vw-sidebar-custom-Content-Sidebar widget_vw_widget_latest_category"><h3 class="widget-title">Sponsored Content</h3><div class="post-box-list"><article class="post-106981 post-box fly-in animated-content post-box-large-thumbnail">
<div class="post-thumbnail-wrapper">
<a href="https://turfmagazine.com/business-management/evaluating-innovation-in-the-lawn-and-landscape-industry/" title="Permalink to Evaluating Innovation In The Lawn And Landscape Industry" rel="bookmark">
<img width="750" height="420" src="https://turfmagazine.com/wp-content/uploads/2022/06/d608f4de-9446-4e12-a021-88568301992c-750x420.jpg" class="attachment-vw_medium size-vw_medium wp-post-image" alt="" loading="lazy" srcset="https://turfmagazine.com/wp-content/uploads/2022/06/d608f4de-9446-4e12-a021-88568301992c-750x420.jpg 750w, https://turfmagazine.com/wp-content/uploads/2022/06/d608f4de-9446-4e12-a021-88568301992c-265x147.jpg 265w" sizes="(max-width: 750px) 100vw, 750px" /> </a>
</div>
<div class="post-box-inner">
<div class="post-categories clearfix">
<a class="label label-small" href="https://turfmagazine.com/category/business-management/" title="View all posts in Business Management" rel="category">Business Management</a><a class="label label-small" href="https://turfmagazine.com/category/business-trends/" title="View all posts in Business Trends" rel="category">Business Trends</a><a class="label label-small" href="https://turfmagazine.com/category/industry-news/" title="View all posts in Industry News" rel="category">Industry News</a><a class="label label-small" href="https://turfmagazine.com/category/innovation/" title="View all posts in Innovation" rel="category">Innovation</a><a class="label label-small" href="https://turfmagazine.com/category/lawn-care/" title="View all posts in Lawn Care" rel="category">Lawn Care</a><a class="label label-small" href="https://turfmagazine.com/category/maintenance/" title="View all posts in Maintenance" rel="category">Maintenance</a><a class="label label-small" href="https://turfmagazine.com/category/manufacturersupplier-updates/" title="View all posts in Manufacturer/Supplier Updates" rel="category">Manufacturer/Supplier Updates</a><a class="label label-small" href="https://turfmagazine.com/category/products/" title="View all posts in Products" rel="category">Products</a><a class="label label-small" href="https://turfmagazine.com/category/sponsored-content/" title="View all posts in Sponsored Content" rel="category">Sponsored Content</a><a class="label label-small" href="https://turfmagazine.com/category/the-latest/" title="View all posts in The Latest" rel="category">The Latest</a> </div>
<h3 class="title"><a href="https://turfmagazine.com/business-management/evaluating-innovation-in-the-lawn-and-landscape-industry/" title="Permalink to Evaluating Innovation In The Lawn And Landscape Industry" rel="bookmark">Evaluating Innovation In The Lawn And Landscape Industry</a></h3>
<div class="post-meta header-font">
<a class="author-name" href="https://turfmagazine.com/author/turf-editors/" title="View all posts by Turf Editors">Turf Editors</a> </div>
<div class="post-excerpt ">There’s a big difference between new and better. Innovating for innovation’s sake should never be the end goal.  Content Sponsored By Innovation. It’s a term ...</div>
<div class="post-box-footer clearfix">
</div>
</div>
</article></div></div><div id="custom_html-7" class="widget_text widget vw-sidebar-custom-Content-Sidebar widget_custom_html"><div class="textwidget custom-html-widget">
<center>
<div id="div-gpt-ad-1467129242315-6">
<script type="text/javascript">
 googletag.cmd.push(function() {
googletag.display("div-gpt-ad-1467129242315-6");
});
</script>
</div>
</center></div></div><div id="custom_html-5" class="widget_text widget vw-sidebar-custom-Content-Sidebar widget_custom_html"><div class="textwidget custom-html-widget"><a class="covid-title" style="font-family: Oswald; line-height: 1.2em; font-size: 2.4em; font-weight: bold;" href="https://turfmagazine.com/category/covid-19/">COVID-19 News</a></div></div><div id="vw_widget_latest_category-9" class="widget vw-sidebar-custom-Content-Sidebar widget_vw_widget_latest_category"><div class="post-box-list"><article class="post-104213 post-box fly-in animated-content post-box-small-thumbnail clearfix">
<div class="post-thumbnail-wrapper">
<a href="https://turfmagazine.com/contractor-profiles/ruppert-landscape-helps-install-flags-commemorating-pandemic-toll/" title="Permalink to Ruppert Landscape Helps Install Flags Commemorating Pandemic Toll" rel="bookmark">
<img width="360" height="360" src="https://turfmagazine.com/wp-content/uploads/2021/09/in-america-ruppert-employees-360x360.jpg" class="attachment-vw_square_small size-vw_square_small wp-post-image" alt="" loading="lazy" srcset="https://turfmagazine.com/wp-content/uploads/2021/09/in-america-ruppert-employees-360x360.jpg 360w, https://turfmagazine.com/wp-content/uploads/2021/09/in-america-ruppert-employees-150x150.jpg 150w, https://turfmagazine.com/wp-content/uploads/2021/09/in-america-ruppert-employees-80x80.jpg 80w" sizes="(max-width: 360px) 100vw, 360px" /> </a>
</div>
<h3 class="title title-small"><a href="https://turfmagazine.com/contractor-profiles/ruppert-landscape-helps-install-flags-commemorating-pandemic-toll/" title="Permalink to Ruppert Landscape Helps Install Flags Commemorating Pandemic Toll" rel="bookmark">Ruppert Landscape Helps Install Flags Commemorating Pandemic Toll</a></h3>
<div class="post-meta header-font">
<a class="author-name" href="https://turfmagazine.com/author/turf-editors/" title="View all posts by Turf Editors">Turf Editors</a><span class="post-meta-separator">,</span>
<a href="https://turfmagazine.com/contractor-profiles/ruppert-landscape-helps-install-flags-commemorating-pandemic-toll/" class="post-date" title="Permalink to Ruppert Landscape Helps Install Flags Commemorating Pandemic Toll" rel="bookmark">September 20, 2021</a>
</div>
<div class="post-categories clearfix">
<div class="label label-light label-small" title="Audio Post"><i class="icon-entypo-note-beamed"></i></div><a class="label label-small" href="https://turfmagazine.com/category/contractor-profiles/" title="View all posts in Contractor Profiles" rel="category">Contractor Profiles</a><a class="label label-small" href="https://turfmagazine.com/category/covid-19/" title="View all posts in COVID-19" rel="category">COVID-19</a><a class="label label-small" href="https://turfmagazine.com/category/industry-news/" title="View all posts in Industry News" rel="category">Industry News</a><a class="label label-small" href="https://turfmagazine.com/category/the-latest/" title="View all posts in The Latest" rel="category">The Latest</a> </div>
</article><article class="post-103604 post-box fly-in animated-content post-box-small-thumbnail clearfix">
<div class="post-thumbnail-wrapper">
<a href="https://turfmagazine.com/turfmagazine/operations-and-services/sustainability-irrigation-water-conservation/" title="Permalink to Irrigation &#038; Water Conservation" rel="bookmark">
<img width="360" height="360" src="https://turfmagazine.com/wp-content/uploads/2021/06/TurfSummer21-IrrigationFeature-Feature-360x360.jpg" class="attachment-vw_square_small size-vw_square_small wp-post-image" alt="water conservation" loading="lazy" srcset="https://turfmagazine.com/wp-content/uploads/2021/06/TurfSummer21-IrrigationFeature-Feature-360x360.jpg 360w, https://turfmagazine.com/wp-content/uploads/2021/06/TurfSummer21-IrrigationFeature-Feature-150x150.jpg 150w, https://turfmagazine.com/wp-content/uploads/2021/06/TurfSummer21-IrrigationFeature-Feature-80x80.jpg 80w" sizes="(max-width: 360px) 100vw, 360px" /> </a>
</div>
<h3 class="title title-small"><a href="https://turfmagazine.com/turfmagazine/operations-and-services/sustainability-irrigation-water-conservation/" title="Permalink to Irrigation &#038; Water Conservation" rel="bookmark">Irrigation &#038; Water Conservation</a></h3>
<div class="post-meta header-font">
<a class="author-name" href="https://turfmagazine.com/author/russ-jundt/" title="View all posts by Russ Jundt">Russ Jundt</a><span class="post-meta-separator">,</span>
<a href="https://turfmagazine.com/turfmagazine/operations-and-services/sustainability-irrigation-water-conservation/" class="post-date" title="Permalink to Irrigation &#038; Water Conservation" rel="bookmark">June 30, 2021</a>
</div>
<div class="post-categories clearfix">
<a class="label label-small" href="https://turfmagazine.com/category/business-management/" title="View all posts in Business Management" rel="category">Business Management</a><a class="label label-small" href="https://turfmagazine.com/category/business-trends/" title="View all posts in Business Trends" rel="category">Business Trends</a><a class="label label-small" href="https://turfmagazine.com/category/covid-19/" title="View all posts in COVID-19" rel="category">COVID-19</a><a class="label label-small" href="https://turfmagazine.com/category/irrigation/" title="View all posts in Irrigation" rel="category">Irrigation</a><a class="label label-small" href="https://turfmagazine.com/category/lawn-care/" title="View all posts in Lawn Care" rel="category">Lawn Care</a><a class="label label-small" href="https://turfmagazine.com/category/turfmagazine/" title="View all posts in Magazine" rel="category">Magazine</a><a class="label label-small" href="https://turfmagazine.com/category/turfmagazine/operations-and-services/" title="View all posts in Operations &amp; Services" rel="category">Operations &amp; Services</a><a class="label label-small" href="https://turfmagazine.com/category/the-latest/" title="View all posts in The Latest" rel="category">The Latest</a> </div>
</article><article class="post-102610 post-box fly-in animated-content post-box-small-thumbnail clearfix">
<div class="post-thumbnail-wrapper">
<a href="https://turfmagazine.com/from-the-editor/turf-spring-2021-issue-we-can-be-heroes/" title="Permalink to Turf Spring 2021 Issue" rel="bookmark">
<img width="360" height="360" src="https://turfmagazine.com/wp-content/uploads/2021/03/Turf-cover-360x360.png" class="attachment-vw_square_small size-vw_square_small wp-post-image" alt="Turf Spring 2021 Issue" loading="lazy" srcset="https://turfmagazine.com/wp-content/uploads/2021/03/Turf-cover-360x360.png 360w, https://turfmagazine.com/wp-content/uploads/2021/03/Turf-cover-150x150.png 150w, https://turfmagazine.com/wp-content/uploads/2021/03/Turf-cover-80x80.png 80w" sizes="(max-width: 360px) 100vw, 360px" /> </a>
</div>
<h3 class="title title-small"><a href="https://turfmagazine.com/from-the-editor/turf-spring-2021-issue-we-can-be-heroes/" title="Permalink to Turf Spring 2021 Issue" rel="bookmark">Turf Spring 2021 Issue</a></h3>
<div class="post-meta header-font">
<a class="author-name" href="https://turfmagazine.com/author/turf-editors/" title="View all posts by Turf Editors">Turf Editors</a><span class="post-meta-separator">,</span>
<a href="https://turfmagazine.com/from-the-editor/turf-spring-2021-issue-we-can-be-heroes/" class="post-date" title="Permalink to Turf Spring 2021 Issue" rel="bookmark">March 12, 2021</a>
</div>
<div class="post-categories clearfix">
<a class="label label-small" href="https://turfmagazine.com/category/covid-19/" title="View all posts in COVID-19" rel="category">COVID-19</a><a class="label label-small" href="https://turfmagazine.com/category/from-the-editor/" title="View all posts in From the Editor" rel="category">From the Editor</a><a class="label label-small" href="https://turfmagazine.com/category/turfmagazine/" title="View all posts in Magazine" rel="category">Magazine</a><a class="label label-small" href="https://turfmagazine.com/category/the-latest/" title="View all posts in The Latest" rel="category">The Latest</a> </div>
</article><article class="post-102166 post-box fly-in animated-content post-box-small-thumbnail clearfix">
<div class="post-thumbnail-wrapper">
<a href="https://turfmagazine.com/turfmagazine/business-management-editorial/employee-safety-keeping-workers-safe-in-the-field/" title="Permalink to Keeping Workers Safe In The Field" rel="bookmark">
<img width="360" height="360" src="https://turfmagazine.com/wp-content/uploads/2021/01/TurfWinter20-BizManagementSafety-Feature-360x360.jpg" class="attachment-vw_square_small size-vw_square_small wp-post-image" alt="Employee Safety" loading="lazy" srcset="https://turfmagazine.com/wp-content/uploads/2021/01/TurfWinter20-BizManagementSafety-Feature-360x360.jpg 360w, https://turfmagazine.com/wp-content/uploads/2021/01/TurfWinter20-BizManagementSafety-Feature-150x150.jpg 150w, https://turfmagazine.com/wp-content/uploads/2021/01/TurfWinter20-BizManagementSafety-Feature-80x80.jpg 80w" sizes="(max-width: 360px) 100vw, 360px" /> </a>
</div>
<h3 class="title title-small"><a href="https://turfmagazine.com/turfmagazine/business-management-editorial/employee-safety-keeping-workers-safe-in-the-field/" title="Permalink to Keeping Workers Safe In The Field" rel="bookmark">Keeping Workers Safe In The Field</a></h3>
<div class="post-meta header-font">
<a class="author-name" href="https://turfmagazine.com/author/turf-editors/" title="View all posts by Turf Editors">Turf Editors</a><span class="post-meta-separator">,</span>
<a href="https://turfmagazine.com/turfmagazine/business-management-editorial/employee-safety-keeping-workers-safe-in-the-field/" class="post-date" title="Permalink to Keeping Workers Safe In The Field" rel="bookmark">January 13, 2021</a>
</div>
<div class="post-categories clearfix">
<a class="label label-small" href="https://turfmagazine.com/category/business-management/" title="View all posts in Business Management" rel="category">Business Management</a><a class="label label-small" href="https://turfmagazine.com/category/turfmagazine/business-management-editorial/" title="View all posts in Business Management" rel="category">Business Management</a><a class="label label-small" href="https://turfmagazine.com/category/covid-19/" title="View all posts in COVID-19" rel="category">COVID-19</a><a class="label label-small" href="https://turfmagazine.com/category/turfmagazine/" title="View all posts in Magazine" rel="category">Magazine</a> </div>
</article><article class="post-102108 post-box fly-in animated-content post-box-small-thumbnail clearfix">
<div class="post-thumbnail-wrapper">
<a href="https://turfmagazine.com/association-headlines/vaccine-priority-for-essential-snow-ice-workers/" title="Permalink to Vaccine Priority For Essential Snow &#038; Ice Workers?" rel="bookmark">
<img width="360" height="360" src="https://turfmagazine.com/wp-content/uploads/2021/01/TurfWinter19-WinterWeather-Feature-360x360.jpg" class="attachment-vw_square_small size-vw_square_small wp-post-image" alt="vaccine" loading="lazy" srcset="https://turfmagazine.com/wp-content/uploads/2021/01/TurfWinter19-WinterWeather-Feature-360x360.jpg 360w, https://turfmagazine.com/wp-content/uploads/2021/01/TurfWinter19-WinterWeather-Feature-150x150.jpg 150w, https://turfmagazine.com/wp-content/uploads/2021/01/TurfWinter19-WinterWeather-Feature-80x80.jpg 80w" sizes="(max-width: 360px) 100vw, 360px" /> </a>
</div>
<h3 class="title title-small"><a href="https://turfmagazine.com/association-headlines/vaccine-priority-for-essential-snow-ice-workers/" title="Permalink to Vaccine Priority For Essential Snow &#038; Ice Workers?" rel="bookmark">Vaccine Priority For Essential Snow &#038; Ice Workers?</a></h3>
<div class="post-meta header-font">
<a class="author-name" href="https://turfmagazine.com/author/cmenapace/" title="View all posts by Christine Menapace">Christine Menapace</a><span class="post-meta-separator">,</span>
<a href="https://turfmagazine.com/association-headlines/vaccine-priority-for-essential-snow-ice-workers/" class="post-date" title="Permalink to Vaccine Priority For Essential Snow &#038; Ice Workers?" rel="bookmark">January 11, 2021</a>
</div>
<div class="post-categories clearfix">
<a class="label label-small" href="https://turfmagazine.com/category/association-headlines/" title="View all posts in Association Headlines" rel="category">Association Headlines</a><a class="label label-small" href="https://turfmagazine.com/category/business-management/" title="View all posts in Business Management" rel="category">Business Management</a><a class="label label-small" href="https://turfmagazine.com/category/business-trends/" title="View all posts in Business Trends" rel="category">Business Trends</a><a class="label label-small" href="https://turfmagazine.com/category/covid-19/" title="View all posts in COVID-19" rel="category">COVID-19</a><a class="label label-small" href="https://turfmagazine.com/category/industry-news/" title="View all posts in Industry News" rel="category">Industry News</a><a class="label label-small" href="https://turfmagazine.com/category/plow/" title="View all posts in PLOW" rel="category">PLOW</a><a class="label label-small" href="https://turfmagazine.com/category/resources/" title="View all posts in Resources" rel="category">Resources</a><a class="label label-small" href="https://turfmagazine.com/category/the-latest/" title="View all posts in The Latest" rel="category">The Latest</a><a class="label label-small" href="https://turfmagazine.com/category/viewpoints/" title="View all posts in Viewpoints" rel="category">Viewpoints</a> </div>
</article><article class="post-102100 post-box fly-in animated-content post-box-small-thumbnail clearfix">
<div class="post-thumbnail-wrapper">
<a href="https://turfmagazine.com/business-management/ppp-the-second-time-around/" title="Permalink to PPP The Second Time Around" rel="bookmark">
<img width="360" height="360" src="https://turfmagazine.com/wp-content/uploads/2021/01/PPP_2nd-round-story-360x360.png" class="attachment-vw_square_small size-vw_square_small wp-post-image" alt="PPP" loading="lazy" srcset="https://turfmagazine.com/wp-content/uploads/2021/01/PPP_2nd-round-story-360x360.png 360w, https://turfmagazine.com/wp-content/uploads/2021/01/PPP_2nd-round-story-150x150.png 150w, https://turfmagazine.com/wp-content/uploads/2021/01/PPP_2nd-round-story-80x80.png 80w" sizes="(max-width: 360px) 100vw, 360px" /> </a>
</div>
<h3 class="title title-small"><a href="https://turfmagazine.com/business-management/ppp-the-second-time-around/" title="Permalink to PPP The Second Time Around" rel="bookmark">PPP The Second Time Around</a></h3>
<div class="post-meta header-font">
<a class="author-name" href="https://turfmagazine.com/author/mark/" title="View all posts by Mark Battersby">Mark Battersby</a><span class="post-meta-separator">,</span>
<a href="https://turfmagazine.com/business-management/ppp-the-second-time-around/" class="post-date" title="Permalink to PPP The Second Time Around" rel="bookmark">January 11, 2021</a>
</div>
<div class="post-categories clearfix">
<a class="label label-small" href="https://turfmagazine.com/category/business-management/" title="View all posts in Business Management" rel="category">Business Management</a><a class="label label-small" href="https://turfmagazine.com/category/covid-19/" title="View all posts in COVID-19" rel="category">COVID-19</a><a class="label label-small" href="https://turfmagazine.com/category/the-latest/" title="View all posts in The Latest" rel="category">The Latest</a> </div>
</article><article class="post-102047 post-box fly-in animated-content post-box-small-thumbnail clearfix">
<div class="post-thumbnail-wrapper">
<a href="https://turfmagazine.com/turfmagazine/business-management-editorial/business-management-lawn-care-pricing-profit/" title="Permalink to Lawn Care Pricing &#038; Profit" rel="bookmark">
<img width="360" height="360" src="https://turfmagazine.com/wp-content/uploads/2021/01/TurfWinter20-BizManagementPricing-Feature-360x360.jpg" class="attachment-vw_square_small size-vw_square_small wp-post-image" alt="lawn care pricing" loading="lazy" srcset="https://turfmagazine.com/wp-content/uploads/2021/01/TurfWinter20-BizManagementPricing-Feature-360x360.jpg 360w, https://turfmagazine.com/wp-content/uploads/2021/01/TurfWinter20-BizManagementPricing-Feature-150x150.jpg 150w, https://turfmagazine.com/wp-content/uploads/2021/01/TurfWinter20-BizManagementPricing-Feature-80x80.jpg 80w" sizes="(max-width: 360px) 100vw, 360px" /> </a>
</div>
<h3 class="title title-small"><a href="https://turfmagazine.com/turfmagazine/business-management-editorial/business-management-lawn-care-pricing-profit/" title="Permalink to Lawn Care Pricing &#038; Profit" rel="bookmark">Lawn Care Pricing &#038; Profit</a></h3>
<div class="post-meta header-font">
<a class="author-name" href="https://turfmagazine.com/author/asanders/" title="View all posts by Alyssa Sanders">Alyssa Sanders</a><span class="post-meta-separator">,</span>
<a href="https://turfmagazine.com/turfmagazine/business-management-editorial/business-management-lawn-care-pricing-profit/" class="post-date" title="Permalink to Lawn Care Pricing &#038; Profit" rel="bookmark">January 5, 2021</a>
</div>
<div class="post-categories clearfix">
<a class="label label-small" href="https://turfmagazine.com/category/business-management/" title="View all posts in Business Management" rel="category">Business Management</a><a class="label label-small" href="https://turfmagazine.com/category/turfmagazine/business-management-editorial/" title="View all posts in Business Management" rel="category">Business Management</a><a class="label label-small" href="https://turfmagazine.com/category/covid-19/" title="View all posts in COVID-19" rel="category">COVID-19</a><a class="label label-small" href="https://turfmagazine.com/category/lawn-care/" title="View all posts in Lawn Care" rel="category">Lawn Care</a><a class="label label-small" href="https://turfmagazine.com/category/the-latest/" title="View all posts in The Latest" rel="category">The Latest</a> </div>
</article></div></div><div id="custom_html-2" class="widget_text widget vw-sidebar-custom-Content-Sidebar widget_custom_html"><div class="textwidget custom-html-widget"><center><a class="twitter-timeline" data-width="300" data-height="1000" data-link-color="#586a54" href="https://twitter.com/TurfMagazine?ref_src=twsrc%5Etfw">Tweets by TurfMagazine</a> <script type="rocketlazyloadscript" async src="//platform.twitter.com/widgets.js" charset="utf-8"></script></center>
<br>
</div></div><div id="custom_html-9" class="widget_text widget vw-sidebar-custom-Content-Sidebar widget_custom_html"><div class="textwidget custom-html-widget">
<center>
<div id="div-gpt-ad-1467129242315-7">
<script type="text/javascript">
googletag.cmd.push(function() {
googletag.display("div-gpt-ad-1467129242315-7");
});
</script>
</div>
</center></div></div></div> </aside>
</div>
</div>

<center>
<div id="div-gpt-ad-1467129242315-0">
<script type="text/javascript">
googletag.cmd.push(function() {
googletag.display("div-gpt-ad-1467129242315-0");
});
</script>
</div>
</center>
<br>
<footer id="footer">
<div class="footer-sidebar">
<div class="container">
<div class="row">
<div class="footer-sidebar-1 widget-area col-sm-4" role="complementary">
<div id="text-16" class="widget vw-sidebar-footer-1 widget_text"> <div class="textwidget"><h3 class="widget-title">Our Sites</h3>
<a title="" href="https://facilityexecutive.com/" target="_blank" rel="noopener">Facility Executive</a> <br> <a title="" href="https://turfmagazine.com/turf-design-build/">Turf Design Build</a> <br> <a title="" href="https://turfmagazine.com/tree-services/">Tree Services</a><br> <a title="" href="https://turfmagazine.com/category/plow/">Plow</a><br></div>
</div> </div>
</div>
</div>
</div>
<div class="copyright">
<div class="container">
<div class="row">
<div class="col-sm-6 copyright-left">Copyright <script type="rocketlazyloadscript" data-rocket-type="text/javascript">document.write(new Date().getFullYear());</script> Group C Media. All rights reserved. | <a title="About Us" href="/about-us">About Us</a> | <a title="Advertise" href="https://turfmagazine.com/advertise-with-us/">Advertise</a> | <a title="Reprints" href="/reprints">Reprints</a> | <a title="Privacy" href="http://groupcmedia.com/privacy-policy-2/">Privacy</a></div>
<div class="col-sm-6 copyright-right">
<a class="back-to-top" href="#top">&uarr;	Back to top</a>
</div>
</div>
</div>
</div>
</footer>
</div> 
<script type="rocketlazyloadscript">window.addEventListener('DOMContentLoaded', function() {jQuery(document).ready(function ($) { $('p').selectionSharer();});});</script><link rel='stylesheet' id='js_composer_front-css' href='https://turfmagazine.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=6.9.0' type='text/css' media='all' />
<script type='text/javascript' src='https://turfmagazine.com/wp-includes/js/comment-reply.min.js?ver=5.8.4' id='comment-reply-js' defer></script>
<script type='text/javascript' src='https://turfmagazine.com/wp-includes/js/jquery/ui/effect.min.js?ver=1.12.1' id='jquery-effects-core-js' defer></script>
<script type='text/javascript' src='https://turfmagazine.com/wp-includes/js/jquery/ui/effect-fade.min.js?ver=1.12.1' id='jquery-effects-fade-js' defer></script>
<script type='text/javascript' src='https://turfmagazine.com/wp-includes/js/jquery/ui/core.min.js?ver=1.12.1' id='jquery-ui-core-js' defer></script>
<script type='text/javascript' src='https://turfmagazine.com/wp-includes/js/jquery/ui/accordion.min.js?ver=1.12.1' id='jquery-ui-accordion-js' defer></script>
<script type='text/javascript' src='https://turfmagazine.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.12.1' id='jquery-ui-tabs-js' defer></script>
<script type='text/javascript' src='https://turfmagazine.com/wp-content/plugins/presso-shortcodes/js/presso-shortcodes.js?ver=1.1%20tacOcat' id='vwscjs-main-js' defer></script>
<script type='text/javascript' src='https://turfmagazine.com/wp-content/themes/tacocat/js/gC-jQ-scripts.js?ver=2.0.6' id='theme_js-js' defer></script>
<script type='text/javascript' src='https://turfmagazine.com/wp-content/themes/presso2-0/js/jquery.fitvids.js?ver=1.1%20tacOcat' id='vwjs-fitvids-js' defer></script>
<script type='text/javascript' src='https://turfmagazine.com/wp-content/themes/presso2-0/js/jquery.isotope.min.js?ver=1.1%20tacOcat' id='vwjs-isotope-js' defer></script>
<script type='text/javascript' src='https://turfmagazine.com/wp-content/themes/presso2-0/framework/flexslider/jquery.flexslider.js?ver=1.1%20tacOcat' id='vwjs-flexslider-js' defer></script>
<script type='text/javascript' src='https://turfmagazine.com/wp-content/themes/presso2-0/framework/swipebox/jquery.swipebox.min.js?ver=1.1%20tacOcat' id='vwjs-swipebox-js' defer></script>
<script type='text/javascript' src='https://turfmagazine.com/wp-content/themes/presso2-0/js/asset.js?ver=1.1%20tacOcat' id='vwjs-asset-js' defer></script>
<script type='text/javascript' src='https://turfmagazine.com/wp-content/themes/presso2-0/js/main.js?ver=1.1%20tacOcat' id='vwjs-main-js' defer></script>
<script type='text/javascript' src='https://turfmagazine.com/wp-includes/js/wp-embed.min.js?ver=5.8.4' id='wp-embed-js' defer></script>
<script type='text/javascript' id='wpb_composer_front_js-js-extra'>
/* <![CDATA[ */
var vcData = {"currentTheme":{"slug":"presso2-0"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://turfmagazine.com/wp-content/plugins/js_composer/assets/js/dist/js_composer_front.min.js?ver=6.9.0' id='wpb_composer_front_js-js' defer></script>
<script type='text/javascript' src='https://turfmagazine.com/wp-content/plugins/selection-sharer/js/selection-sharer.js?ver=0.1' id='selection-sharer-js-js' defer></script>
<script type='text/javascript' src='https://turfmagazine.com/wp-content/plugins/pdf-print-pro/js/html2canvas.js?ver=5.8.4' id='html2canvas.js-js' defer></script>
<script type='text/javascript' src='https://turfmagazine.com/wp-content/plugins/pdf-print-pro/js/jspdf.js?ver=5.8.4' id='jspdf.js-js' defer></script>
<script type='text/javascript' id='pdfprnt_front_script-js-extra'>
/* <![CDATA[ */
var pdfprnt_file_settings = {"margin_left":"15","margin_right":"15","margin_top":"16","margin_bottom":"16","margin_header":"9","margin_footer":"9","orientation":"portrait","page_size":"A4","file_action":"download","file_name":"STIHL Sponsors Philadelphia Flower Show Highlighting Innovative Landscapers","header_footer":null};
/* ]]> */
</script>
<script type='text/javascript' src='https://turfmagazine.com/wp-content/plugins/pdf-print-pro/js/front-script.js?ver=2.3.2' id='pdfprnt_front_script-js' defer></script>
<script type='text/javascript'>window.addEventListener('DOMContentLoaded', function() {
			;(function( $, window, document, undefined ){
				"use strict";

				$( document ).ready( function ($) {
							$( '.flexslider' ).flexslider({
			animation: "fade",
			easing: "easeInCirc",
			slideshow: true,
			slideshowSpeed: 4000,
			animationSpeed: 600,
			randomize: false,
			pauseOnHover: true,
			prevText: '',
			nextText: '',
			start: function( slider ) {
				slider.css( 'opacity', '1' );
				slider.find( '.post-thumbnail-wrapper' ).css( 'height', '500px' ).imgLiquid().fadeIn(250);
			},
		});
					} );
				
			})( jQuery, window , document );

					});</script>
<script type="rocketlazyloadscript">window.addEventListener('DOMContentLoaded', function() {
jQuery(document).ready(function(){
        jQuery("#page-content .post-content div").css("margin-bottom", "0");
        jQuery("#page-content .post-content div div").css("margin-bottom", "10px");
    });
});</script>

<div id="div-gpt-ad-1467129242315-9">
<script type="text/javascript">
 googletag.cmd.push(function(){
googletag.display("div-gpt-ad-1467129242315-9");
});
</script>
</div>

<div id="div-gpt-ad-1467129242315-14">
<script type="text/javascript">
        googletag.cmd.push(function() {
        googletag.display("div-gpt-ad-1467129242315-14");
        });
      </script>
</div>
</body>
</html>
